Working on big dwg with many many blocks - rhino can't handle

Hi,

I try to work with dwg file which has 180 mb - most of data is in blocks. I got 16 gb ram and ssd disk but emory is 95% used and everything stops. I’ve changed in windows disk cache from 10 gb to 50 gb but rhino seems to use only ram and can’t handle that.
Is there way that rhino use cache on hdd combined with ram?
Or other way how to increase efficiency?
Cheers,
Marek

Hi Marek,

Please run SystemInfo in the Rhino command line and post your results.

There are a lot of variables here, can you zip and upload the file to McNeel so we can take a look?

Please put a description of the issue and a link to this post in the upload. Thanks.

Hi Japhy,

Here you can find sys info.

About uploading the file. I work on layout of new factory we plan. There are confidential data.

If you can assure that you only use the file for analysis and then delete the file I could as my boss.

Problem with such files is that we got layout of hall in size 500x150 metres full of machines which are somehow extracted from solid works or similar software and converted to 3D. Such block Is full of blocks, if you extract, then you got more blocks because every screw is in block.

To work on it I extract all blocks and then use purge. Although it consumes 95-99% of memory and freze.

Topic on forum:

Visit Topic

SYS INFO

Rhino 7 SR35 2023-12-12 (Rhino 7, 7.35.23346.11001, Git hash:master @ 6916542aa86609e2c43094fedcff51a3bd3c5723)

License type: Komercyjna, build 2023-12-12

License details: Cloud Zoo

Windows 10 (10.0.19044 SR0.0) or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Unplugged [71% battery remaining] ~90 minutes left

Non-hybrid graphics configuration.

Primary display and OpenGL: NVIDIA GeForce GTX 1650 (NVidia) Memory: 4GB, Driver date: 10-26-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 472.47

Integrated accelerated graphics device with 4 adapter port(s)

  • Windows Main Display is laptop’s integrated screen or built-in port

OpenGL Settings

Safe mode: Off

Use accelerated hardware modes: On

Redraw scene when viewports are exposed: On

Graphics level being used: OpenGL 1.1

Anti-alias mode: 2x

Mip Map Filtering: Linear

Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation

Render version: 4.6

Shading Language: Niewspierane

Driver Date: 10-26-2021

Driver Version: 30.0.14.7247

Maximum Texture size: 32768 x 32768

Z-Buffer depth: 24 bits

Maximum Viewport size: 32768 x 32768

Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

C:\Users\poledniokm\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\NVIDIADenoiser\0.4.0\NVIDIADenoiser.Windows.rhp “NVIDIADenoiser.Windows” 0.4.0.0

Rhino plugins that ship with Rhino

C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.35.23346.11001

C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”

C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.35.23346.11001

C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.35.23346.11001

C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”

C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”

C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.35.23346.11001

C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.35.23346.11001

C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”

C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

C:\Users\poledniokm\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SectionTools\2021.4.30.511\SectionTools.rhp “SectionTools”

Best regards,

Marek

Any file provided to McNeel is considered confidential & private and will not be used in any manner except troubleshooting your issue.

Hi,

Unfortunately we can’t send this files.
Problem with our dwg files, that they have thousands of block definitions. I.e. we got some part of drawing which is in block, this block contains many blocks and this blocks also contain some blocks (like screws etc).
With smaller files I’ve handle that I’ve exploded everthing, then purge, then file was much lighter (100 MB dwg changed to 15 MB).
To explode or purge ive needed to left pc for night.
The problem is, that all ram memory is used.

So i got few questions:

  • Is it possible to force rhino to use paging file?

  • Is it possible to lower “level of details” like in autocad i mean if you see circle from outside its not like polygon? Will it help?

  • Rhino does not seen groups made in audocad and autocad does not see groups made in rhino. Can you fix it somehow?