Working away from origin WORSE in Rhino 6 than in Rhino 5

I thought the whole issue with working away from origin was supposed to be better in Rhino 6 than in Rhino 5?.. In my experience the graphics are better. No more jittery geometry. This is great!! But now I’m having issues with setting geometry to Grasshopper and Make2D (which was also supposed to be better, and it really is 10x better when at origin)

I get a huge lag when inputing the surface that is away from the origin inside the TEST_V6 file attached. At origin works perfect with no lag and both surfaces, at origin and away from origin, in the TEST_V5 work perfect.

Additionally I’m getting poor results with Make2D when it is away from origin in V6 as opposed to V5.

Is anyone else having more issues with working away from origin than previously in V5? Does anyone know why this is happening? If it is something that will get fixed? A larger issue that will only get resolved in V7?

Bueller??.. haha… really, any insight would be greatly appreciated THANKS

Both attached files have the same geometry in the same place with the same units, just one is saved as a Rhino 5 and the other Rhino 6.TEST_V6.3dm (1.4 MB)
TEST_V5.3dm (1.2 MB)





Away from Origin V6

At Origin V6

Away from Origin V5

At Origin V5

Hello - so far I do not see this here in Make2d in either file.

Can you please run SystemInfo (Help menu > System information) and paste the results here?


Hello Pascal, thanks so much for the reply!

Here is the System Info, by the way this has been replicated on two other machines in our office so it is strange to me that you are not getting the same result. For clarity’s sake I have reorganized the geometry in the file and re-attached it to this post. It is the Geometry in RED that is having issues (surface lagging when imported to GH and triangles not accurate when using Make2D). I’ll also repost the settings for Make2D that I was using… Did you have lagging when importing the surface to Grasshopper?

Rhino 6 SR5 2018-6-4 (Rhino 6, 6.5.18155.13161, Git hash:master @ 0e00e118078ee9a651d609817f672fb0ed8e83bf)
Licence type: Commercial, build 2018-06-04
License details: LAN Zoo Network Node

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: CRWMJ05YLYQ

Quadro M2000/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 384.76)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 6-27-2017
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”

TEST_V6.3dm (1.4 MB)

Hello - thanks – with your settings I see the same result - the missing lines are being interpreted as ‘hidden’ for some reason - thanks for the report.

And I see the lag in GH as well.



Thank you Pascal for tracking these issues!

Do you know if there have been other complaints about working “away from origin” with V6 compared to V5?


I might be reading too much into this, but this could be what @DavidRutten mentions here:

1 Like