WISH - V5 - "Update Selected Blocks"


#1

WISH - V5 - I’d like to have a command to “Update” or “Refresh” Blocks. It would be nice to be able to update all blocks that are “not up-to-date” without having to open the Block Manager. I think this would be a time saver.

Wish number-2 would be to have a new command that would “Update Selected Blocks”. Again, why wait for the Block Manager to scan all the blocks when I just want to update a block and it’s already selected. Sometimes this would fit my workflow better than double clicking blocks to open them.


(Pascal Golay) #2

Hi James- I’ll add this to the pile if it is not there- in the meantime, there is the ‘UpdateSelectedBlocks’ script here:

http://wiki.mcneel.com/people/pascalgolay

that may help.

-Pascal


#3

Thanks Pascal. Exactly what I was looking for!

Jim


#4

The updated selected blocks script does not seem to be any faster though then opening the block manager and selecting the objects there, I was hoping it would bypass checking all the blocks and being much faster in updating a single or a couple of blocks. But either the script is not working properly for me, or it takes just as long as using the block manager.


#5

The script seemed a bit slower than a normal file save when I 1st started using it. I don’t know if it’s related to the newest Rhino update(SR7), but now it seems way slower.

I timed a couple things to check it out.

  • Open BlockManager and update: 23 seconds
  • Using the “Update Selected Blocks” script: 1 minute, 20 seconds
  • Open the block(double clicking) / save: 42 seconds(to an updated and unlocked assembly)

This is a big assembly file and I expected the BlockManager to take much longer to open than it did. Maybe that’s been improved. I’m surprised how long the script took. I didn’t time it before, but is seemed faster than this.

Jim


#6

I had the hopes the script would be faster, but have a similar feeling as you do now, the script seemed to take quite a bit longer then updating trough block manager.


(Pascal Golay) #7

Hmm- let me check to see if I am doing something stupid in the script- I probably did not test with large numbers of blocks are the files you are using it in very large, or, are the linked blocks on a network, possibly? Anyway, I will take a look and see if there is any obvious change I can make.

thanks,

-Pascal


#8

The file I tested has 68 blocks inserted. Many are duplicated with a total of 472.
The assembly file is 29mb.
The block I did the time test is 25mb.
The whole assembly when exploded comes out to 471mb (for what it’s worth…)

I like the double click to edit blocks feature when I have the block files closed out. Frequently, however, I like to have 2-3 blocks open and I’m making changes to them and want to be able to move around the assembly file to see how things relate. This can’t be done when the file is locked. This makes the script really handy. Even if the time was equal, it’s less clicks than opening the BlockManager.


#9

Pascal,

Forgot to answer your question. All the blocks inserted and the assembly file are on a network.

Jim


(Pascal Golay) #10

Hi Jim- how many block instances do you select, typically, to update?

thanks,

-Pascal


(Pascal Golay) #11

Hi all- see if this is any better at all…

UpdateSelectedBlocks (2).zip (618 Bytes)

-Pascal


#12

I’m using a file of 138 MB, Total size of blocks 1600 MB, I was just trying 1 block, and they are on a network drive.

I’m guessing around 1800 blocks in the scene


#13

Just tested new script,

[UPDATE]

  1. Old script: very very long.

  2. New script: took 15 minutes to update 1 (simple) block.

  3. Opening block manager: 4 min, Updating 1 (simple) block: 4 min -> total 8 min


#14

I would also like to have Block Library Preview (refer to attached image) and drag&drop facility. it would also be good to have and intance preview when editing live block. just like in SketchUp.

thank you


#15

This would be quite handy, and also easier to search blocks you have used before in the scene, at the moment I use “insert” and then scroll trough the drop-down menu searching for a number in a large list of numbers.


#16

Usually just 1. Sometimes 3-4.


#17

Tried the updated script.

I ran it on the same file that took 1 minute 20 seconds.

With the updated script, it took about 4 seconds…

Thanks Pascal!

Jim


#18

So for James it did work, but seemingly for a larger file it does not work.

@pascal perhaps you have any other suggestions?


#19

I just dropped in a large block (270mb) and updated it. It took 30 seconds. I thought that’s about what it would take to open the block by itself. It took 55 seconds to open the same file(drag & drop in another instance of Rhino).

Jim


#20

Some more details:

Size of blocks: ~200kb and ~30mb.
Amount of unique blocks: 426
Total Size of blocks: ~1.5 GB
Total blocks in scene: 3306
Size of scene: 138 MB