Wish : globally turn off edge softening

Hello, the edge softening tool is a great thing that I use on a daily basis for a large number of the geometry in my projects, there is however one problem…
When edge softening is used in large projects on a number of objects it slows down the display pipeline dramatically.
To overcome this problem I would like to have the option to temporarily turn off all edge softening while modelling, and turn it on when i would like to render. Of course this option has to include the feature that each objects has to remember its own edge softening amount and the it has to work also for objects in blocks…

best

Andreas

5 Likes

Hi Andreas - got that, thanks, I’ll add it to the pile - I guess this would apply to all of the render mesh ‘special effects’.

https://mcneel.myjetbrains.com/youtrack/issue/RH-37258

Also, @walther - for now, if you select everything you can control the ‘on’ state of EdgeSoftening etc from there, for all objects at once in Properties.

-Pascal

I am sorry to dig this one out again, but it is still bugging me even though 4 years ! have already passed…

Although Pascal mentioned that you can off course select everything and then turn of the edge softening this is not a very good solution:

  1. We need a tool to be able to select objects where the soft edging is failing

“The edges could not be softened because the softening radius is too large.”

this error message often seems to come up when reopening projects where I used soft edging, they do not seem to appear directly after applying soft edges! The problem is there is no way to Identify / select the objects where it fails !
2. Selecting everything and then turn off soft edges is destructive, since you do not have the option to revert that action since you do not want to apply soft edging to all objects.
3. Furthermore this method does not work for objects within blocks…

So imagine opening a large project consisting of objects with and without soft edges and 50 blocks also containing objects with and without soft edges. After opening the scene you are greeted by 40 error messages that soft edges are failing on some objects… I think you get the idea…

Best

Andreas

1 Like

one more thing I forgot to mention:
What is also super annoying is the fact that the error message “The edges could not be softened because the softening radius is too large.” combined with very noticeable displayport lagging is also occurring when you execute other operations, which are completely unrelated to these objects but (I guess) force Rhino to remesh parts of the scene… I think I remember that e.g. pasting geometry or unhiding hidden parts trigger this behaviors as well…

Push

1 Like

McNeel please ! This is a real problem, this post is 5! years old and the issue is giving me problems on a daily basis.

Can someone please look into this ?

Hi Andreas -
In a simple test file here, it is possible to turn edge softening off and on with macros without running into issues.

Can you please share a simple 3dm file that shows the The edges could not be softened because the softening radius is too large issue?
-wim