Wish: Cursor sensitive snap search-break

@pascal I think it would be a great benefit if Rhino could be more cursor movement sensitive when snapping to large meshes.

Right now we are working with an imported arc model with lots of cladding and when I try to vertex snap it can be really slow to move the cursor over the model as Rhino tries to find the snap for all the cursor positions along the way.
(Hope that long sentence makes sense :wink:

So if Rhino could check the cursor position while looking for potential snaps and break the search if it has moved x pixles away from when Rhino started the search (say 30 checks a second) we should be able to smoothly move the cursor over the model when trying to draw a curve while vertex snaps are on. As it is now I get up to 3 seconds lags and since I use the icon to start the polyline I have to move the cursor back over the model and, well I guess you see the problem.
(the workaround is to type polyline with the cursor in the right position, but still it is slow to move it to the destination)

Cheers!

Hi @Holo
You can hold down Alt to momentarily disable osnaps until you are in the “target area”.
HTH, Jakob

Hi Jorgen - how big is the mesh? I have a test with two million-plus faces - the snap is indeed a little bit behind the cursor movement but not enough that I think it slows down workflow enough to prompt your note… I’m guessing what you see is worse for some reason.
What I do see is that on stopping the snapped vertex is not the one closest to the center of the cross hairs, I am not sure what iis happening there.

image

I guess it is doing some depth testing - it seems to bias the snap to vertices that are closer to the camera.

-Pascal

Hm… yeah, it doesn’t act as bad on the home workstation. (very comparable systems, with a tad faster pcu, but a bit slower gpu) So I need to check this out. The file has around 1000 objects + a few referenced files, so quite heavy, but I do not see the 3 sec lag (only half a second, so it could still benefit from the wish)
Edit: this is strange, after selall unselect all it is much faster… I need to check this out. Maybe some updates are going on in the background, I know my workstation had to update when I shut it down today. I’ll be back!

Thanks! Great tip!