Wish: Ability to automatically switch OSnap based on the command

Is not it better to implement an optional switching of the OSnap based on the active command? I lost count of how many times I had to turn off OSnap while using “Blend surface”, for example. Adjusting its handles is pain while OSnap is turned on. In rare occasions I use OSnap to set the position of a new handle or move an existing one, but that’s only a fraction of the whole time spent on the tool. The same goes for command like “Adjustable curve blend”, “Adjust end bulge” and others where the main focus is to fine tune the handles and avoid unwanted interference by the OSnap.

Also, for certain objects the “Cen” (center) OSnap is way too aggressive, especially on planar surfaces and closed planar curves. In a brighter future, the user should be able to choose in the settings whether the “Cen” OSnap will snap to planar surfaces and curves, or not. Unlike that, the “Cen” OSnap rarely works easy on circles while “Near” is also active, which is pity, because the circles are the exact type of objects that need a very robust center snap that’s not dominated by the “Near” OSnap.

The ALT key can be used as Osnap toggle.

I’m very used to BlendSrf and I found helpful dragging the points and holding Alt key to turn the Osnap off.

Of course the procedure is important:
ALT + dragging= rotating the handle
DRAGGING +ALT = Osnap off

Hope this helps.

You could include the Osnap settings into the command you’re using. Are you invoking the mentioned commands by an alias or button?

1 Like

That sounds like a possible solution, at least for the “Blend surface” and similar commands. I use the default icon for “Blend surface”. I set the “DisableOsnap Toggle” macro to the F1 key on my keyboard. Do you think that this could be implemented as a macro in the “Blend surface” button so that it will turn off the OSnap upon starting to adjust the handles. But the problem is that the OSnap also have to turn on automatically after the blend surface is created.

I’m aware that the Alt key temporarily toggles the OSnap, but I use a 3d mouse with my left hand and I try to minimize the movements of my hand towards the keyboard as much as possible. :slight_smile: It also may mess up the adjustment of the handle by accidentally rotating it, as you mentioned above. This is why, when I run the “Blend surface” tool I only use the Alt key to rotate a handle.

Putting _DisableOsnap _Disable in front of _BlendSrf will work. However, somehow anything put after BlendSrf is not working (at least not here) It might have to do with the fact that this is a dialog command, idk. Maybe @pascal knows how to make this work.