WIP installation errors (Cycles not running)

During installation of wip version 6.0.16131.20501, 10.05.2016 i got this error message popup:

After clicking OK, the install went through. I´ve then opened the wip and was not able to switch to cycles render:

After having rhino open for 2 minutes, this dialog came up:

it offers an option to uninstall and repair, imho it is missing an OK button to get rid of it…


It looks like something is going on with the roll-out of new versions lately.

When I was running 16117 (2016-04-26), I got the message that a new version was available for installation - 16124 (2016-05-03). When I started to install that version, I get a message that an update was available - 16130 (2016-05-09). I downloaded and installed that one instead.

Yesterday evening - when checking things to reply to this thread - I saw that a new version was being downloaded - 16131 (2016-05-10) but this morning, when I wanted to install this one, I get a new message saying that an update is available - 16132 (2016-05-11). That’s the one I’m running now.

A short while after install and launch, a similar dialog box pops up, and I assume that one has to click the X at the top right to get rid of this. An OK would be nice here, yes.

As for the Cycle thing you mention, @clement, how do you switch to “Cycles for Rhino”? A while ago, the Cycles rendering plugin was taken out and then only the realtime version thereof was available as the display mode called “Raytraced”. The only available render engine (as such) is the Rhino Render:

Note that the Cycles for Rhino plug-in isn’t yet part of the official Rhino WIP - it is still released separately for brave beta testers. I’ll have a look at the plug-in right after my current Rhino WIP build process completes and release a newer version when it works for me.

I’ll notify this forum again when I do release here https://github.com/mcneel/RhinoCycles/releases



@Wim, i guess the plugin was just out of date, Cycles still worked in Raytraced display mode over here regardless of the Renderengine chosen. After updating the plugin to version 0.0.2 it worked again :wink:


yes, but where / when do you get the “Unable to make ‘Cycles for Rhino’ the current render plug-in” message?

In the screenshots that was printed to the Rhino command-line - so during start-up loading of the plug-in failed, resulting in that error message on the command-line.

Woah, that’s really weird. There are a bunch of install logs in your temp directory. Can you please send them to me?

  1. In Windows Explorer address bar, type %tmp% then press Enter
  2. Sort the files by date, newest at top
  3. Scroll down until you find Rhino_*.log - there will be several of them, probably right next to each other
  4. Please zip all those files and send them to me: brian at mcneel dot com

@brian, ok i’ll sent the last 5-6 logs from yesterday via pm.