WIP icons almost impossible to see in light mode

Hi McNeel
The default dark mode in the latest WIP looks great, and I’m sure that it’ll make a lot of users very happy - it’s been asked for time and time again. I personally like the light mode, so I switched it back, but the icons - specifically the line/curve tools icons - are close to impossible to see on my 3840x2160 monitors (screen scale 150%, which is the recommended scale). The lines/curves come across too thin and blurry. Can this be adjusted somehow/somewhere?
Dark mode
image

Light mode
image

TIA, Jakob

Edit: OK… weird… restarted the WIP and icons back to normal/readable.

1 Like

Hi Jakob -
Thanks for the update. I started typing this up as a YT issue but restart worked here as well…
I think that this is something that is being typed on every day at the moment, but keep the feedback coming.
-wim

2 Likes

I’m loving the new default Dark mode as well. Is there a built-in way to switch between dark and light modes without the SetColorScheme plugin? I couldn’t find one.

image

1 Like

Geez, yeah, just installed the latest WIP update and now my custom workspace (inherited from V7) looks like this:

A restart of Rhino didn’t fix it. I don’t have a “Default” radio button like @DanBayn shows above:

I set it to light, the icons look better (but too light):

But it also nuked all of my other custom color settings - background, grid, etc.

Then I set it back to “Custom” and got this:

So it did not retain my previous custom settings and now I need to recreate those…

Well, yeah, it is WIP software I guess… :face_with_spiral_eyes:

EDIT: something is definitely broken here. I reset my background color to my usual dark gray and hit OK, the change was not accepted and it went back to the default light gray. And going back into ETO, the color choices were no longer visible as in my 3rd image above. Had to click “Light” and the “Custom” again to get them back. Changed the background again and this time it stayed…

However, every time I open the ETO colors section, the color settings are not shown, have to click Light or Dark, then back to Custom to get them back. And doing so nukes most (but not all) of the custom color settings and sets them to default. Only the major/minor grid color settings seem to “stick” when this is done.

My complaint here is when it comes to popup toolbar, I get the icons not legible in the dark mode, see examples:

Figured I’d start a new response for how it works in the WIP with the default workspace - here is a quick video:

As you can see, it comes up looking OK, but then everything goes south. It is set to Light to begin with, If I click Custom the color choices come up, OK. But if I then go back to “Light” and click “Restore Defaults”, it reverts to Dark. And if I go back to “Light” from there, many of the icon colors are messed up.

And it’s no longer fixable - well, it is actually, but in a weird way which I accidentally stumbled on - you have to click “Light” again, then instead of hitting OK, hit “Cancel”. Then it goes back to “normal”…

Very bizarre. There is definitely some crossed wiring there.

Hi Mitch,

I noticed that difference too, in the latest build. I took that screen capture before I updated this week.