WIP Freeze

unhandled

#1

After a few minutes not using Rhino, it freezes… Cannot spin around viewports, but can save and exit successfully!

Running:
Work In Progress
(6.0.17150.8211, 30/05/2017)


#2

It just happened again. It seems to be the viewports because I’m able to select a new command in the command line and implement it, but it just doesn’t show in the views!


(Nathan 'jesterKing' Letwory) #3

What display modes are you using while this happens? Any specific model open while it happens? Or does it happen with default startup, empty scene and wireframe display modes?


#4

There’s a mix of modes across multiple viewports - wire, shaded, rendered.


(Nathan 'jesterKing' Letwory) #5

Does this happen with an otherwise empty scene?


#6

Haven’t tried it.


#7

This happens every time I leave rhino maximed on the screen unattended for 3 or 4 minutes. Doesn’t seem to happen if I minimise the session. To add, I’m using a second display.


(Nathan 'jesterKing' Letwory) #8

So to reproduce:

  • start Rhino with maximised window and empty scene
  • leave open by itself for some time (4 or more minuted)
  • Rhino frozen

?


#9

In this case, it’s a working scene - I haven’t tried it yet with an empty scene.


(Nathan 'jesterKing' Letwory) #10

@sach, do you have in your working scene a Raytraced viewport in use?


#11

NO ray-tracing happening!


(Nathan 'jesterKing' Letwory) #12

Ok, that is good news for me, because it means it is not my code causing the freeze. Maybe @stevebaer knows more.


#14

Hello

I’ve just tried some configurations:

Second display plugged in in extended mode. Happens both when Rhino is displayed on the primary display which is my Dell Precision M3800 laptop, and also on the second Dell display.

When I unplug the second display, the issue seems to go away!

Thanks
Sach


(Brian James) #15

Thanks for the extra details. Can you do two things to help pinpoint the issue on your system…

1- Check if it happens with an empty scene when the second monitor is used.

2- Run the SystemInfo command and paste the results here in a reply.

Thanks!


#16

Hi Brian

Yes, it happens with an empty scene when the second monitor is used.

Here is the sysinfo:


Rhino 6 SR0 2017-6-6 (Rhino WIP, 6.0.17157.8191, Git hash:master @ 6f22a30c15f92cf2fa7034205c1ded8909c03f4b)

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)

Quadro K1100M/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 376.84)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: None
Anisotropic Filtering Mode: None

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: NA
Driver Version: NA
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 64 MB

C:\Program Files\Rhino WIP\Plug-ins\SolidTools.rhp “SolidTools” n/a
C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Rhino Render” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI” n/a
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp “Snapshots” n/a
C:\Program Files\Rhino WIP\Plug-ins\CyclesForRhino.rhp “Cycles for Rhino” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” n/a
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” n/a
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement” n/a
C:\Program Files\Rhino WIP\Plug-ins\MPlane.rhp “MPlane” n/a