Windows.forms bug in r6 template or VS17?

Hey all, took a quick swing at recompiling a simple command for R6. nearly zero issue, but my windows forms code for saving spat the dummy, forms was greyed out in the references, and all my save code highlighted red… autosuggest was indicationg I should use rhino.ui as forms was deprecated, which I tried but its missing some forms functionality I want…

after going around in circles for a bit, I removed reference to rhino.ui, added windows.forms back in after deleting it as a reference and hey presto, problem gone…

so now my code looks exactly the same as it did when I first pasted it in, but suddenly works and compiles? Any idea why it spat the dummy on windows.forms?

1 Like

Hi @ChristopherBotha,

Sounds like a namespace conflict. In such cases, it is best to provide a full qualified namespace.

– Dale

Hi Dale

I tried moving two other plugins over. Same issue.

Removing the using for windows forms, (cut) allowing intellisense to go nuts then readding it (paste) fixes the glitch. No actual change in the using statement at all. Ill try grab some video of it today.

Regards CB