Windows Black In One Hidden View

I have a layout page where all details have my window material showing as black in a hidden view.

On another layout, the material reads correctly as nothing, as the Hidden view mode is set not to show textures and display all surfaces as the same white colour.

I copied from the black-displaying page to the correct page, and now I have the below. Two identical views of the identical objects set to the identical view modes. The windows in the left detail show correctly. The windows in the right detail window are black. But all settings are the same. I don’t have time to break the project down and try and create a link and send it for diagnosis, but I thought I’d register this issue with Current Rhino on Windows 10. Never had this issue before.

Hi @djhg,

Without checking the file is difficult to know what is going on.
Can you send me the 3DM file to visualarq@asuni.com?

Thanks,

Enric

Luckily it fit into an email. Just sent it, thanks Enric.
I sent the .ini file for my Hidden View mode in a separate email.

There’s definitely something happening in this project. New windows don’t display at all in my details. The hole in the wall is there, but the windows aren’t visible. Windows which have been there for a while are still displaying, at least, though they display as a black material.

Hi @djhg,

I can’t reproduce the issue. This is what I see when I open you model:

I’m using Rhino 7 SR15 and VisualARQ 2.12.3, just like you. I’ve also imported your “Hidden.ini” display mode. I think there is something else that is causing this. Does it happen just after you open the file?

Regards,

Enric

I tried with “Print preview” enabled and disabled.

Enric

It happens regardless of restarting the project or the computer. Its consistent day to day. I will look for an update for my display driver.
DG

Hi @djhg,

I don’t this this issue has relation to the graphics card driver.

Which graphics card do you have? I’ve tested on an AMD, but we can try to reproduce the issue in a GPU more like yours.

Thanks,

Enric

Its a 3050 ti.

Apologies. It’s a GTX 1050 ti

I’ve reinstalled the driver, but it doesn’t change things. THere’s somethiing wrong with this file here, and it’s not just windows. It’s not respecting section fill settings on my roof - it’s showing it as a solid black fill in Hidden Display Mode, though it’s set to be a solid grey fill, and displays that way in other modes.

When I start a new project, none of these issues are present in that same HIdden Display Mode with Roofs or Windows - the display follows the settings.

In the model you sent me, the roof does not have any section hatch pattern assigned. I tried setting the hatch pattern to “green solid”, and it seems to work fine in hidden display mode.

image

I’m running out of ideas… There must be something different in your computer. Do you have any third-party plugin or Grasshopper add-in installed?

Enric

Va is my only plug-in. That’s correct, I’ve added the hatch to the roofstyle since uploading that project.

There’s more: It seems that in this project in Hidden Mode, I can select windows by clicking on the face of any of its component objects. I can’t select anything else (a wall, for example) unless I select an edge. (this is of course with Print Display off). The faces should be transparent as with other objects. (This facilitates the layering I do, with Rendered Views behind Hidden Mode views.)

Also: I have recently created a polysurface as a muntin pattern in the window. That object displays as opaque white, unlike other objects in hidden mode, whose faces are transparent. (no material adjustment will change this). In the case of these windows, the muntins, sassh, and frame are a dark grey colour so the work-around it to create a hatch in layout space. But somethings corrupted in the way Hidden Mode is displaying windows and objects within their bounds.