Win10 auto update closes Rhino

Win 10 carried out an automatic update involving a shutdown and reboot while I was away from my desk…… ‘censored comments’

This action closed Rhino, unsaved for a few hours (happens sometimes!). I realise that Autosave is a crash recovery tool and the file is deleted at successful shut down. Clutching at straws, I thought I’d check out the help file to see if there was a saviour I wasn’t aware of.
From the Help file:
“If Rhino is not successfully closed, either because it crashed or because you turned off your computer while your file was open, the autosave file remains on your hard drive”

The question is, does Win10 forcing Rhino to close unsaved, signal a successful shutdown to Rhino (no autosave), or the computer being turned off while a file was open (yes autosave)?

Edit; thinking about this a bit more, I had 4 sessions open and 2 of them were open for reference, therefore, unsaved. Maybe one of these was closed last - no autosave.

The question becomes, with one Rhino instance and file open (saved at some stage in the session), will an Autosave file exist if Win10 forces a shutdown?

Hi Brian - as far as I know, yes.

@JohnM - is that correct?


Twice since switching to Windows 10, I have lost Rhino work because I left the PC with files open and it went into Sleep for a long time (not sure how long, but more than 3-4 hours). Upon waking it, the Rhino file(s) are closed, with no warning message or reminder displayed. Any work that wasn’t saved prior to this was lost (censored comments here too). The files in question don’t flag up any warning messages about unsuccessfully closed or a crash when they are re-opened either. Autosave didn’t bail me out. This never used to happen with Windows 7.

This is why I refuse to update from 7 pro on my graphics machine. I this microsoft is looking at class action law suit with these forced upgrades. I had a friend have his computer upgraded while he was asleep because he left it on.
I personally think it is up to the user to do what he or she wants done on their machine.

All my best … Danny

Win XP pro was their best OS and I used it until I purchased this last graphics machine and they advised me to go with 7 pro.

The answer is it depends, if the “Options/Files/Autosave/Save every” is set and the model is modified a save timer will get trigger which should attempt to save after the “Options/Files/Autosave/minutes” time. The file will be saved in either the “Options/Autosave/Autosave file” folder or in “%APPDATA%McNeel\Rhinoceros\5.0\AutoSave” if the Autosave file value is empty and be name something like _Rhino5Autosave.dwg. If Windows force closes Rhino and Rhino is unaware then the file created by the save timer is the only Autosave file Rhino will create.

I guess the short answer is if autosave is enabled and a model was modified and the autosave time has elapsed prior to Rhino being forced to close you should at least have that save file.

Thanks Pascal and John,

I suspect my file would have been saved then if I only had one Rhino open. Trouble is, I nearly always have more than one instance open with files in various stages of saved or unsaved, so it becomes a lottery as to which one will be saved.

This is actually the 3rd time this has happened in the last couple of months. Is it unreasonable to request an autosave for each open file to go on the heap?

While searching autosave problems here, there were a few cases of disappointment where people expected autosave files to exist in similar situations to this - maybe it should be called something like ‘crashrecovery’ instead of autosave, so we don’t get our hopes up and maybe have a delay on the deletion so that when we close without saving, for example, it’s possible to retrieve the autosave(s), and you only lose minutes instead of hours.
To see autosave kick in every 20 minutes and then press the wrong button on exit… can’t catch it… Gone!

AutoSave does save each open file - as long as you’ve saved it at least once (i.e. has a unique file name).

Thanks Wim, I’ll get back to my rework.

Same thing happened to me yesterday…
Win X has installed upgrades and told me to reboot, I refused and as soon I was away from my desk (about 40min.) the pc did the reboot automatically.
Rhino’s Autosave is set every 15 min but the file I was working on wasn’t saved (the file was one day old and I was editing it).
In the autosave folder I found only 3 files: two were created on january and one was made yesterday morning about a file made to try some commands and closed without saving it (in fact it’s name was autosave.3dm).
My computer go in standby mode 3 - 4 times in a day and never lost the files that were opened by a program… this was the first time.
I suppose that’s a Windows problem that told to the programs to close without saving (like it was a user’s choice).
At the end I’ll pay more attention to my open files before leaving my desk but I hope that something a little bit stronger can be made to Rhino’s autosave side.
Thanks and ciao!

To clear up my mis-understanding I’ve carried out a trial which created multi autosaves, then I shut down the pc without saving. The multiple Rhino autosave files survive as they have been designed to do, so it appears that when Win10 takes control of your computer and does a reboot-required update without waiting for user permission, it manages to force Rhino to carry out a successful, unsaved shutdown and in the process deprives you of your backup and time!

Does anyone know how to disable this Win10 automatic disruption and keep the reboot warning on screen until you are able to save your work?

Win 10 Pro has settings to allow updates to only be performed at certain times. As far as I know, Win 10 Home/Standard does not allow for this. I’ve got Pro (more by luck than judgement) so I’ve now changed things to give me more control over unattended shutdowns and restarts.

Perhaps the Idle Processor settings in Rhino could be used to provide an alternative line of defence from this behaviour, by using it to save the file after, say, 20 minutes if it’s left unattended?

Seems like a durn-good idea - have you tried this?


No, not yet. It only occurred to me as I was typing…

Thanks for the suggestion Matt, works well…

Thanks for this solution too Matt, the default active hours in win10 is 8 to 5 and my problem occurred at 5.40pm so I’ve now extended these active hours.

Somewhat frustratingly, Microsoft only believes you can use a computer for a maximum of 12 hours, so active hours are rather limited.

Is this true for professional versions as well?

Unfortunately, yes.

See, they care for Your health: don’t overwork!


That must be it! Real pros know when to quit.