Why so lose hinges in Kangaroo2 example?

In the Kangaroo2 SliderArm example there are two types of axial hinges in the slider arm. One hinge is very “stiff” in that it cannot lean to the sides, only rotate around it’s (hinge) axis, which is a Line. But some other hinges are defined by two points on each object (positioned where the axis endpoints would have been located had the axis been defined as a Line in).

Now, the latter hinges are not “stiff” sideways, but can with mild force be brought to lean, although there’s no room in the hole for leaning axially on an axis with the same diameter as the hole it goes through.

Q: Now my question is: What kind of loose and “unruly” joint or hinge is this meant to illustrate? Hadn’t it been better to use a (“stiff”) Line also for these hinges?

// Rolf


@DanielPiker, is this something you can help with?

Thank you for the hint. I found the following example, which illustrates very well what I expected and find more useful for more rigid mechanical applications :

(Edit: Ops, something went wrong with the link. Fixed.)

// Rolf

After more detailed analysis of the SliderArm model I realize that I didn’t understand the model at first glance (there were no “lines” defining hinges, only points).

But what still puzzles me is that I cannot select the any objects (arms or points) although the point data (the cross markers) are shown—

Edit: Found the problem (solved). Objects where hidden, but display was “overlapped” by GH preview so they didn’t appear to be hidden. Hm. That displaymode should be indicated more clearly. Causing much confusion for newbies (like me).

// Rolf

In any case, the hinges (or colinear slider) in that very model doesn’t seem to stick to the cylinder it is supposed to slide along. Instead it’s unstable and allowed to tilt “sideways”. I’ve tried to reattach the (yellow) slider in different ways, but no go. Problem looks like this when dragging it extremely outside its (expected) constraints:

Is this unstable tilting due to a problem with the model, or due to a bug in the components? (I have Kaangaroo 2.1.4 installed, fresh install)

Ping @DanielPiker

// Rolf