Why doesn't it look like shaded surface is matching edge curves?

Created an EdgeSrf from 4 edge curves. In shaded view when I zoom in it doesn’t look like the surface is matching the edge curves. Is this a mismatch due to tolerances, or just a shading issue?

Anyway to make it fit better either way?


Increase mesh density in Options panel.

Thank you, solved.