Why does one extrusion not appear with this script?

Hello, so I was following a youtube tutorial to learn Grasshopper and it worked for the most part except for one thing. There is one element where the extrusion doesn’t happen correctly. When I change the graph on the script, then the position of the faulty element changes. What am I missing and is something wrong with my script? Adding a screenshot and the script if anyone can spare a little time to help.

Parametric 1.gh (30.3 KB)

All breps are closed here.

What’s your tolerance setting in the Rhino file?

Hey @martinsiegrist thank you for responding!

Its pretty much the same as what you sent.

I also cannot reproduce the issue here with the same default tolerances.
Are you on the latest version ?
Can you check in the output of Extrude what you get for this extrusion, is it open or invalid Brep ?

Maybe reverse the vector for the extrusion so it goes in a positive direction (so move by -x and extrude by 2*x)…

1 Like

@magicteddy that is so strange… I just ran the script on a different PC and i got the same issue. I will try your suggestions and see fingers crossed

Hey, @magicteddy. So yes I have the latest version of Rhino, I’m not too sure how to check if the brep is open or invalid. Tried changing the expression as you suggested and it didn’t work.

I went on a hunch though, and I tried changing the graph a bit and noticed that I didn’t have an issue any more as shown below.

But when I change the graph again, I have this issue again

Any idea as to what may be causing this or is it some very weird bug that im experiencing on 2 different PCs?

My guess is that the profile self-intersects on that case, making it impossible for Rhino to create a planar surface on the sides.

@magicteddy that might be it. Thank you so much for all the help!! I really appreciate it!