Why does my render not resemble the material preview?

I’m simply trying to achieve some non-wonky transparency in my objects so curves can be seen behind. What appears in the material allocation preview render looks fine, but when I do an actual render the material is way off appearance.

Thanks for your help forum.

Exhibit A – This looks great:

Exhibit B – The render-output is very opaque and not at all like the material preview (or the Rendered viewport which also looks fine and is not opaque like this output):


You can try setting IOR to 1 & setting transparency to less than 100%.
Maybe change color from white to grey for the transparency color

IOR defines how the light is refracted through, so setting to 1=air and light is not refracted.
But if you set transparency to 100& it won’t render anything so changing the transparency to like 80% should get what you are looking for.


Thank you Toshiaki,

Setting the IOR to 1 worked, but it still looks different than the Rendered Viewport and Material Preview – what is that?

You might want to check the setting under, Rhinoceros->Preferences->Display Modes

In the setting, under color and material setting should be set to “Rendered material”.
If this is set to others I think it’ll look non-transparent.

1 Like

It seems curves doesn’t get rendered behind objects even if render curves are set on.
You might try using pipe command to make the lines into an actual surface, using very small radius to represent a line.

1 Like

You read my mind with the pipe idea – I do wish the curves would render behind the transparent object but beggars can’t be choosers I suppose. =)