Why can't I get Rhino to always generate clean STL files?


#1

A lot of the times when I use the STL files generated by Rhino into a third party STL analysis tool like Magics or Netfabb I see these software report problems with STL such as intersecting triangles. Thus requiring manual repair within these programs.

Why does this happen sometimes? If Rhino says a surface is valid closed polysurface shouldn’t STL files always come out without intersecting triangles?

Does it have something to do with my mesh settings? I basically followed the official [webinar][1] where is was recommend to zero out all the field in the “Polygonal Mesh Details Options” window except for “Max distance, edge to surface” and “Minimum initial grid quads”. Please see attached screenshot. (I’ve set edge to surface distance to the tolerance value and initial quads between 100 to 400)

[1]: https://vimeo.com/80478910


(Pascal Golay) #2

Hi numan- please post an example of this if you can, - that is, the Rhino geometry, SaveSmall, not the stl file - or send it to tech@mcneel.com.

thanks,

-Pascal


#3

Unfortunately I can’t publicly share the file. Will email it. Thanks


#4

The Rhino Level 2 Modeling course had a good little tutorial on page 159:
http://www.rhino3d.com/download/rhino/5.0/Rhino5Level2Training/