Why are locked layers interfering with Osnap?

Attached a scene file example.example.3dm (546.9 KB)

I have 2 layers. One layer contains 3 reference pictures. The layer is completely locked.

My main layer is where I’m to build curves. I have Osnap enabled, as you can see in the UI. I even have the setting SnapToLocked disabled.

Despite all of this, Osnap stops working on my curves anytime the mouse is remotely near one of the locked pictures on the locked layer. As you can see in my screenshot, the mouse is hovering directly near the curve, but OSnap is simply not working. It’s like the locked picture is somehow stealing attention away from the cursor. This is driving me insane, because I have to hide the picture layer completely in order for it to work properly.

Doesn’t work:

Does work

Why is this happening and how do I stop it?

Hello - I don’t know… I’ll see if I can reproduce this.
It seems OK here -that is, if I get close to a point, the snap takes over as expected - from what I see on my screen, the cursor location in your top image is just at the edge of the snap radius (You can check snap radius too, in Options >Modeling aids, but that should not be an issue if it works with that layer hidden. At any rate mine is at 15 pixels) Can you try turning only the Point Osnap? Does that behave any differently?


Nope, that doesn’t work. Here’s a video. You can see clearly what’s happening wrong here. Any points “in front” of the locked picture will select/osnap properly. Any points that are near or “underneath” or intersected by the picture plane don’t work.

Hello - see if setting SnapToOccluded sorts it out.


Sadly, nope, still doesn’t work:

Hi -

In that video, you show that you have SnapToOccluded disabled.
The snapping system doesn’t check the alpha transparency of your Picture object and so this is considered to be occluding what’s behind it. You need to enable SnapToOccluded to be able to snap through objects that occlude other objects.

I see that it’s not very intuitive when you use a picture with transparent background but I’m not sure if it would make more sense if you can snap through parts of that picture that happen to be transparent and not through other parts of that picture.

At any rate, there are a few other things that seem to be getting in the way of a smooth ride here but - if you don’t want to work with SnapToOccluded enabled - you can work around those issues for the time being:

  • Select your Picture object and, in the Properties > Material panel, set the transparency to, e.g., 25%.
  • Lock the Picture object
  • If you want, you can then also lock the layer that this object is on. It doesn’t suffice to only lock the layer, though. You need to lock the object itself.

I’ll log a few YouTrack items…


  • RH-58871: OSnap: Make locked layer behave like locked object
  • RH-58872: OSnap: Make locked picture behave like locked surface
  • RH-58873: OSnap: Allow snapping through (semi-) transparent objects