White isolines, how to get rid of them?

As you see this is quite disturbing and I tried to tweak the layer properties, but nothing :frowning: Imported them as obj into TSplines and converted into NURBS. Thanks for your help!


Select the object(s), go to Properties, uncheck the “show isocurves” box. That won’t change the surface’s knot distribution of course, just the display. --Mitch

No I like the lines, but they are white and I want to change them into something grey or black. Thanks @Helvetosaur for your quick help on this!

Ah… OK. If you want to change them all (surface edges and isocurves), you can just change the object’s color. Since changing the layer color doesn’t change the object color in your case, the object color has already been set to “by object” and not “by layer”.

You can again select the objects and go to Properties, then go to “Display color” and either choose one of the basic colors or “other” to bring up the color picker.

If you are looking to change the surface edges independently from the isocurves, that can only be done by modifying a display mode.

HTH, --Mitch

Mitch it’s only about the Isocurves and lines that are surprisingly rendered white. Default is black as we know. but there is no location to set them back to normal colour. @Helvetosaur

Hi Hannes- what is the display mode in that viewport? Does it have some custom settings?


Sorry @pascal don’t have the file anymore. Will post here if I encounter it again. Promised — thanks for your support anyways. H

@pascal this is the file link. If you have a time to check them out. Thanks a lot for getting into this!



Hi Hannes - I do not yet see why these display in white in the first place, but you can fix the display be selecting all of the objects, changing the display color away from black, and then back to black.