White edges SketchUp Import


#1

When I import from SketchUp or from OBJ my geometry has white edges. Is there any way I can change that so the SketchUp object looks like other Rhino objects? Both objects in the attached JPG are on layer Default.

Thanks for any advice you can give.


#2

Might they be mesh objects that have a different edge display color than your surface objects? Or blocks that have curves concurrent with the edges? If you post a sample file someone can look…

–Mitch


#3

Because the object’s display color is different from the layers color the object is on.


#4

That was it. I was only looking at the Layers panel. I put both objects on the same layer so I assumed Display would be the same. But selecting the objects and looking under Properties I see that Display Color is different.

Thanks for the guidance. I have a vast amount of SketchUp work stretching back over several years and I need to be able to bring it into Rhino when my ‘repeat offenders’ clients call for revisions or new versions of old projects.


#5

Yes, now it seems incredibly obvious, good call.

Of course, this will only be confusing with pure black and white object colors with the opposite as layer color… because Rhino, in its infinite wisdom, displays the surfaces of white objects as… gray, and the surfaces of pure black objects as… the same gray. With any other color combo, the difference of the object color from the layer color will most likely be more obvious…

–Mitch


#6

Hi guys,

I wonder if I could jump in to this? I also have had problems with Sketchup imports for years. I usually work in Shade mode and when I bring in a Sketchup model it also has grey surfaces with white edges: See attached lamp png. What I want to do is have the lamps displayed the way a regular nurbs object would be: grey surfaces and black edges. I don’t see how the display color makes any difference. I wonder if you would be kind enough to be more specific… step by step. How would we change it (if we can) to grey surfaces with black edges?


#7

I suspect the object color is white and it has ended up on a black layer. Just select the object(s) and go to properties and set it to “by layer” (if the layer is indeed black), or object color to black will also work no matter what color the layer… Does that work for you?

White and black surfaces are the same gray shaded, but surface edges and isocurves are layer color (unless you have changed that in a display mode - which is also possible in Windows.

–Mitch


#8

Hi Mitch,

I have attached the 3dm file for you to look at. The Sketchup’s properties are set to by Layer and the Layer it’s on is black. I even went to the Display settings for Shaded and changed the Mesh Edge Settings of the mesh objects so to “Use single color for all edges” and set the color to black and that didn’t change it either.

Puzzling.

Lamp with white edges.zip(91.0 KB)


(Willem Derks) #9

Hi Cosmas

Try to set the display color to By Layer as in the screenshot below
Does that help?

-Willem


#10

Hi Willem,

Yes!! That did it – but why? Can anyone explain that to me? When I set the Display Color to “By Layer” it’s color (as you can see in the screen grab above) is white. Yet it immediately resolved the problem

Thank you.

Years of Sketchup import frustrations are now solved!


#11

No, the layer color is black in Willem’s screenshot… Note the black square by the layer name…

–Mitch


#12

That’s interesting. If you look at the attached screen grab, you can see that my Display Color is set to “By Layer” is white-- and yet the edges have become black. Could this be a bug?


#13

The box next to “by layer” is always a “blank” white - it doesn’t change color…
–Mitch


#14

Thank you, Mitch. Really appreciate it. You have made my relationship with the Google 3d Warehouse infinitely better: )


#15

A minor comment - if the object in question is a block instance, the setting has to be changed in blockedit. I choose Trimmed Planes and make sure Display Color is set to By Layer for all geometry including blocks and I seem to be getting very clean geometry from my SketchUp files now that this minor issue has been cleared up.


#16

Good comment. Object color in blocks is often “by parent” and not “by layer”.

–Mitch


#17

For anyone who sees this thread later…jCOMPONENTS (Blocks) that come from SKP files, need to be EXPLODED before the layer colors/line colors will be changed. Don’t think anyone mentioned this yet in the thread


(Pascal Golay) #18

Hi Alan - you may be able to get there via BlockEdit, if I understand your comment.

-Pascal


#19

Yes, thank you I should have also commented that. But I noticed a lot of times the blocks have been resized, in which case that’s not poss, correct?