Which light source causes shadows if every light is disabled?

Hi everyone,

when I turn of sun, skylight and any lights, there still remains a light source:

Maybe I am missing a crucial point in rendering here, but I couldn´t find out how to disable this light source (what is it?).

With the sun enabled, it looks like that (not quite what is should look like, there are two shadows):

lights-panel

have you tried with shadows unchecked from the display tab?
image

That doesn´t make any difference.

and this?

Interesting, your ghost light produce a quite soft shadow, so it’s doesn’t seems to be a sun.

I would try to select all object, hide them and create simple surface and a cube. If the light effect is still there than the ghost light can’t be selected and hided. If the ghost light is gone, than I would go back and look where it is.

Does running ‘SelLight’ in your scene reveal any lights that might have unintentionally come in with an FBX or other asset import?

There is a “hidden” default light setup used if nothing else is, could it just be that?

What display mode are you using there?

→ Doesn´t change anything, same result.

→ SelLight: there are no lights.

→ I don´t know what this default light setup is or how to change or disable it. But normally, it doesn´t look like this.

→ the images are rendered. But the rendered display mode looks different: it´s all white, I can´t see any objects (even with sun and skylight disabled).

→ The light effect is still there, even if everything is hidden:


(no sun, no skylight, no lights)


(sun)

Ok, this effect was caused by an object with an emission material I didn´t know was there. So problem solved.

And this effect seem to be caused be the default light setup, so it´s ok:

I didn´t know that there is something like a default light which is used if there are no other light sources. That was kind of confusing here…

Good that you solved it.

Raytraced/Rhino Render will indeed render light when there is an object with an emissive material and the object is placed correctly.

When all lights are out you indeed also get the default light, which is a directional light (like the sun) essentially over your left shoulder.

When I don’t want any light I always add a point light somewhere inside some geometry and set its intensity to 0

1 Like