Where is Cycles? (V6)

Nvidia Control Panel Settings

the image shows my Nvidia Control Panel 3d Settings

here are the settings shown in the OpenGL Extension Viewer

It shows that the current nvidia driver is using opengl version 4.6

under Tools > Options > Advanced check if your core profile setting is set to true. If it is flip it back to false.

flipping the setting UseCoreProfile to false did not allow cycles rendering with OpenGL:

see this video screen capture:

https://www.dropbox.com/s/snlf2ji7zxq24mq/opengl.mp4?dl=0screen capture

Once you’ve flipped the setting to false you need to restart Rhino I think.

Wohoo that did the trick Setting it to false and restarting Rhino worked. Now the correct OpenGL version is displayed in the opengl tab of Options:

Now what is the UseCoreProfile setting for and what would the benefit of selecting yes be. IE: why is the true/false setting there to begin with?4.6

You may have set it sometime earlier, maybe even during the v6 WIP cycle. There may have been builds out there that had Raytraced crash while drawing with OpenGL, setting core profile may have helped. Maybe some other reason to work around.

thanks yes while trying to figure out my view port odd behavior I think I changed it.

@nathanletwory You didn’t directly answer this part:

I’m curious too. In fact what is a “Core Profile”?


Core Profile is a profile for OpenGL where deprecated calls are completely disabled. We use this generally for troubleshooting, and users generally shouldn’t fiddle with this.

Raytraced drawing through OpenGL doesn’t work that well through Core Profile.

The OpenGL part is used only for putting the Raytraced results onto the screen - the ray tracing is still done fully on the GPU. With core profile (and/or UseDrawOpenGl set to false) the showing of the results is done in an alternative, slower method.


I see. Thanks again, Nathan.

thanks again for your help. Great to know that this forum has such helpful people.


I am having the Same issue. Raytraced looks like rendered, I have no cycles in the options pop-up and RhinoCycles can’t load in the plug in manager.

Hi @chris24,

Can you right-click RhinoCycles and disable load-protect? Will it load after that?


Hi @DavidEranen

Thanks for your response.

I can click disable but it doesn’t work…


Did you try to load the plug-in after disabling the load protection?

It won’t let me disable load protection

So no checkmark appears after RhinoCycles in the list?


Right-clicking again would still show Disable Load Protection.

I can check it but it automatically unchecks itself when i exit the options pop up

How peculiar. Can you maybe check if the plug-in RHP file is somehow blocked on your machine? If you click on the RhinoCycles plug-in to the right you should see some info and a details link. Click that to get a dialog with among others a link to the path where the RHP file lives. Click that link to open the file explorer. Then check whether the RHP file is blocked or not.

If you have antivirus software, also please check to see if it hasn’t for some reason quarantined any of the RhinoCycles files.

If that doesn’t work I am out of ideas - maybe a repair of the Rhino installation is necessary?