When re-tagging same curve in grasshopper Galapagos output geometry changes, but parameters stay the same

Hello All!

I am using Galapagos to generate a generative building perimeter based on views. I ran my algorithm a couple of days ago. Here is an image of the level 1 floor plan which I originally got from Galapagos last week.

Since then, I have accidentally deleted the 4 curves which serve as the bounding edges for each building. Because of this, I re-drew my four perimeter lines in rhino and re-tagged them as multiple curves in grasshopper. This is where it gets strange… The buildings all of a sudden change shape, but the building parameters which were outputted from Galapagos stayed the exact same. Here is an image of the new level 1 floor plan:

Here is an image of my output geometry from galapagos which DID NOT CHANGE:

Does anyone know why/how this is happening? And how to fix it?? Even if the buildings were just being rearranged within the four plot outlines the order of the output parameters in Galapagos would have changed. View oprimization San Francisco All Floors.gh (9.9 MB)

I tried to run your example, but there are referenced curves. You need to either “Internalize” the curves and re-post the example, or post the 3dm file. Also, it will help if you can share a minimum possible script that one can test, and preferably without external plugins (you are using Bifocal). Right now you have a big definition, and it can be slow, and hard to identify the issue. The more tidy your example, the more likely people will be able to help.

1 Like