What to adjust to make skin show reality shape?

Hi,
V5

I have selected my objects, gone analyse, zebra adjust mesh and simple controls and dragged slider fully right, yet I am still measuring visually 0.35mm stick out of brown ribs beyond surface. It had me thinking I have got the sections wrong, they were trimmed with skin as cutter. Once milled it will be too late. I select skin and see an isocurve following the outside edge of ribs so all is well.

However I cant do a screen grab and show client how it will be with this looking as such. and for my own sanity this has got to be better displayed than this. My vid card has 4Gb of ram and is the latest killer vid, so how do I get rhino to make a better job of displaying this skin ?

Steve

Turn off the layers containing the ribs or Hide the ribs?

Dunno, that looks kinda suspicious to me… The isocurves of the wing surface do not look like they follow the outside edge of the ribs in your image. If you run Intersect between the wing and a rib, what does it give you? It should just give you the outline of the rib on the surface if it’s just touching.

If this is a display thing then it’s pretty bad… The “triangly” interference pattern of brown/gray you see near the center of the image (in the form of a “C”) is the normal display of concurrent surfaces, it’s the interference of the two display meshes with different colors that occupy the same place in space. I would expect to see that on the ribs as well, but I don’t, so I suspect they do actually stick out in places. Intersect will tell you…

If they really are concurrent, then maybe your wing has an inaccurate display mesh, could be several things causing that, if you’re not too far from the origin, it might just be your mesh settings…

–Mitch

Hi,
David…trouble is I need to show the ribs in conjunction with the skin , else yes turn them off.

pics of intersects and what was selected.
Note the middle blunt rib in first pic doesnt even intersect yet appears to be sticking out.


Steve

Steve, read the document on mesh setting, which Helvetosaur provided the link to. Then try a custom mesh setting with a tighter “max distance edge to surface” setting. You might start with 0.1 mm and if that is not good enough try 0.01 mm, though not less than several times the absolute tolerance in Units. But as Helvetosaur said above concurrent surfaces will have a mottled appearance.

OK, your mesh settings do appear to be very coarse you can see very large visible facets in the first image. The info in the wiki page I posted should help, you will need to find a reasonable max dist edge to srf value for your objects so that they display better.

In any case you will always see concurrent surfaces to some degree.

–Mitch

Hi,

Bit odd this, as I had selected the objects then gone analyze and dragged the mesh slider simple controls fully right, thinking that would set my mesh. It doesnt appear as such to have made changes to the mesh settings…as…
I read the article, thanks,…go file>properties>mesh and see its set to jagged !!!

As such did altering slider under analyze option form a temporary change ?

screen dump shows result of smoother, then also of custom and values are shown.
certainly custom even just entering 0.01 fixed it, then I also opted for 35 for density, not sure if that value would be overkill seeing that 0.01 saw an immediate change but for tight curves it might come in handy.

Steve

If you read this page, you will see that there are separate meshes for display and analysis. So one setting does not affect the other.

–Mitch