Weird render of wood materials with edited SCU

So, I applied wood materials on a door and its rails, and used “ApplyMappingSCU” (French “AppliquerPlaquageSCO”,not sure of the translation, I couldn’t find the exact command.)
It works fine on regular perspective render, but when I try to do a proper render, the grain becomes much wider and it doesn’t look like wood. Any idea what must be done?

Cycles still broken and useless - doesn’t understand OCS Mapping

Post the 3dm file please of just the door with that material. Use the Export command to save out only the current selection and I’ll take a look.

Rhino render support.3dm (3.1 MB)
Here you go. Not the same door, but the problem is the same, and I built it using the same method.
Thanks for the help.

As mentioned in the linked YT item you can work around the problem for now by ensuring you have a different order of setting the OCS frame. Current you have its X axis on the world Z axis, its Z axis along the world X axis.

Instead something like this works:

1 Like