Warning! Offset surface no longer preserves the original seam of a pipe!

I just noticed after the latest Rhino 7 update that “Offset surface” with the “Loose=No” option will no longer preserve the original seam of the pipes. It basically splits the original surface into two halves, so that there are two seams now. Is there a good reason for this change to be introduced? Splitting the offset pipe into two halves basically makes it impossible to extract the original pipe with a single seam that was used to add thickness to it. Unfortunately, that will directly affect all the projects where working with pipes is crucial, such like chassis design, etc.

1 Like

Hello - as far as I can see so far, splitting happens in V6 and V7 if the output is Solid=Yes.


Hi Pascal, I don’t remember if that was the case in Rhino 6. The last time I designed a chassis with pipes (round tubes) was several years ago and I’m not sure if it was Rhino 5 or 6. Now that I need to design a new chassis with pipes this change in the offset surface comes as a surprise to me. What was the reason to split the original surface into two halves? This is something usual for SolidWorks since many years and it’s not pretty…

Hi Bobi - can you offset with Solid=No?


I also have another question. Why a straight pipe is Degree 3 with 4 rows of control points since the input line is Degree 1 with just 2 control points? This particular inconsistency leads to the need to manually remove the extra rows of control points either with ! _RemoveControlPoint or ! _ChangeDegree.
In my opinion, the output pipe should follow the same principle as the input line and be with Degree 1 along the length. Not sure if a macro could be made to convert a straight pipe (but not a curved one) into Degree 1 pipe.

Yes, I usually do my offset surfaces (not only pipes but also any other shape) with “Solid=No”, and that produces a proper offset pipe with a single seam, preserving the original, too. Then I can manually add the end cap surfaces with the ! _PlanarSrf command. However, once I trigger the “Solid=Yes” option of the “Offset surface” tool, it splits the original pipe into two halves for no obvious reason.

Hi @Pascal , is there a way to produce clean pipes that are the same degree 1 as the input curve, as shown in post #5? Looks like a bug to me.



1 Like

I’m having the same problem right now.

Clean pipes. Doing a solid=yes offset will change starting surface to two halves!
Why so? It doesn’t make any sense.

Now i’m manually doing all the steps:

  • offset solid=no
  • cap original pipe
  • solid difference between capped and offset

This manual method always work, but take much more time.
Maybe it’s not, but this feels like a bug…


I agree that it’s super annoying, especially for someone who designs stuff entirely with tens and even hundreds of pipes. Splitting the pipe into two halves just ruins the general idea of the modeling and makes any further modifications of the pipes a real pain. There is a zero reason for the pipes to be split into two halves with the “Solid” option set to “Yes” while everything works properly with the same option set to “No”. :woozy_face:

Having to manually change the degree of a simple straight pipe from 3 to 1 is another thing that should be fixed. I already mentioned that in an earlier post. Currently, I design a car chassis and I’m forced to modify each pipe manually, which adds a huge amount of mouse clicks and time.

Yet another annoying problem while working with pipes is the wrong direction for the “Split” command while trying to split a pipe with the “Isocurve” option in the Command line. The default direction is “U” along the length of the pipe, whereas it must be set to “V”, because 99,9% of the time pipes are usually cut across. :slight_smile: