Vray render - unknown command

unhandled

#1

Hi guys,

When I press the render tab on vray it says unknown comman, but it lets me do a region render though… has anyone had any experiance with this?


#2

Type ‘render’ and see if the command works.
If it does, check the button by shift-right-clicking on it and choosing 'edit’
This is what there should be as left mouse button" (left area of the button editor)

! -_RunScript (
Option Explicit
Dim VRay
Set VRay = Rhino.GetPluginObject("V-Ray for Rhino")
VRay.SetRTEngineOn False
VRay.SetDistributedRenderServerEnabled "localhost", False 
)
_render

#3

Also, is V-Ray set as the current renderer? If it get switched to Rhino Renderer, then the V-Ray stuff won’t work.


#4

Thanks! Much appreciated


#5

Yes vray is set to current


#6

OK, cool.

I also have occasional problems with the license dongle. Every so often, it loses its ‘connection’ and is not recognized. I just unplug it and plug it back in. If you hear the windows “bloop-bloop” then it’s probably fixed. If not, close Rhino and re-boot. That has always worked.


#7

Hi there,

I have a very similar issue, but my button script is that same as previously mentioned.

Im currently running Vray for Rhino 2.0 on Rhino 5. My machine is running windows 7, and we have an uptodate license dongle which we ulternate between two rendering machines.

The issue is that neither of Vray render buttons work, and typing in the command ‘render’ either launches the Vray Render command OR the RealTime Render command, depending on how the file was saved i presume and i cant alternate between them.

Like Shawn i can also ‘Render in Window’.

Vray is set as current renderer. I have reinstalled both Rhino and Vray, tried many reboots and ensured both programs have the most recent patches.

The error command when is click either of the buttons is:

Command: -_RunScript
Unknown command: -_RunScript

Any ideas?

Thanks