Vray materials

We try to attach vray material to a VA window in the windows option:

It looks Ok on the Rhino render window:

When we render the image in vray the glass is white:

test.3dm (348.8 KB)

Hi Simon, this should work fine with VisualARQ 2.5.2 version and VRay 4.00.02

We use VisualARQ 2.5.2 and VRay 3.60.03. In this case, we will upgrade VRay.
Thank you very much.

I confirm, the render with vray 4.00.02 works fin.

1 Like

I’m having the exact same issue with rendering Visualarq windows in Vray Next. The glass renders the same as the frame (parent material), if the frame is wood the glass renders as wood, even though it’s in layer glass with glass material assigned. I’ve tried many adjustments in the attribute options but no luck. I’ve tried both rhino and Vray materials. With the rhino render the glass renders correctly as glass. Exploding not an option. I have latest versions for both Vray Next and VisuaArq, downloaded them last week.

Please advise, thanks.

Hi @connie,

Are you using the interactive render or the standard render command of V-Ray?

VisualARQ objects should render fine in V-Ray 4.02 when using the Rhino Render command.


I have tried all V-ray render modes, standard, interactive and progressive all have the same problem. The glass component always renders in the material of the parent window. If the window is red paint, the glass renders as red paint etc. There are two ways to make the glass render as glass: assign glass material to the window layer (the frame renders as glass too) or explode, obviously neither is good. By the way, in the native Rhino render everything renders correctly. Also, when I select objects in “glass” layer in Rhino, I get zero objects - unless I explode, then Rhino sees them.
I have tried different options in attributes but no luck yet. Thanks for your help.

![window wood|563x450, 75%](upload://eDQLA8CU98vtZ![Window glass|563x450](upload://wWTALhZXeyoeVAlB0SS0wWindow glass window wood exploded window wood Rhino render window wood asQwAK.png) tq7e51qafaggHI.png)

Follow up to my last post, attached are four tests, the first three in V-Ray standard mode and the fourth in Rhino Render:

  1. Glass assigned to both layers “window” and “glass”

  2. Exploded window in foreground (renders correctly)

  3. Wood assigned to layer “window” and glass assigned to layer “glass”

  4. Everything renders correctly in Rhino render

Hi @connie,

Can you please confirm that you are running V-Ray Next 4.00.02 and VisualARQ 2.6.1? You can check the plugin versions in the Rhino command line or in the Rhino Plugin Manager, inside the Options dialog.

Also, send the model to visualarq@asuni.com so I can take a look?



Turns out I had downloaded last week an evaluation version from the Novedge website which was the 2.5 older version, not the updated 2.6 - even though their site calls it 2.6, what gets installed is the 2.5, which caused the problem. If anyone from Novedge reading this, please note.

I uninstalled and downloaded an evaluation directly from the VisualArq site, this time it was the correct 2.6 version and everything works fine, glass renders correctly.

Thanks for the help.