Volume and Area Analysis Broken v7

I have a simple model of extruded closed stair steps. I can check volume and area in v5 but not v7, same model.

Can you please post the model so the problem can be investigated?


Won’t check area or volume.

Started off as an extrusion then exploded to see what might work. Restarted my computer. Tried in v5 and can do the analysis.

Steps_Check.3dm (155 KB)

Hello - Area works here for the surfaces and Volume works if they are joined into a closed object.

Cumulative Area = 11345.8212 (+/- 1e-05) square inches for 12 objects
Volume = 43268.8611 (+/- 1e-05) cubic inches

Are those the numbers you expect?

What do you get, an error message, incorrect answer, or?
It could be that a bug was fixed - please run SystemInfo in Rhino and copy/paste the results.



Ok, I figured it out. It’s kind of a stupid mistake but it would be better if you could make it so it can’t happen.

I had the command history section pushed up so it wasn’t exposed as you can see in the top of the image of the attachment. Since the analysis is displayed there I never saw it. For me a pop up window or display in the properties panel would be more idiot proof.

It’s kind of the same situation for me that I reported a few years ago when I run “Make 2d”. The first time that command is run the new layers are created and the highlighted output can be seen. After that I usually turn that layer off so the next time I run Make 2d the output is not shown since the layer is off. Took me a while to figure out what I had done without an error message.

And while I’m here. V7 is installed on my desktop and I need to travel so I installed on my laptop. The install message was confusing. “Use here or post the serial to your account” This seems to be a change and when I go from machine to machine I’m asked about turning the license off on the other machine and on to this one. I’ve never seen that before. Is there a change to the usage? Or am I now using the Rhino Zoo? Used to be able to install on 2 machines and go back and forth.

Thanks for you guys getting back to me even if it was a silly mistake.

Randy Primozic

c- 608.628.7302


Hello - if you have your Rhino license in your Rhino account, and you have left it in use on another machine, you need to close either one or the other - the license can only be in use on one machine.