Visualisation error in a new file after [Ctrl+C]

Hi there,

I copied geometries, wich were created in grashopper, from an existing file to an other one. In the first piture you can see the geometry the way it should look and the second one is the one with the visualisation issue.

I guess it is no hardware related issue but i updated the graphics card driver anyway, but any improvements happened.

Does anyone know how to solve this?
Btw, is there something similar to reduce mesh command for polysurfaces? Even that could be the issue, as it was inserted in a heavier file.

Hi - does this get better if you run ClearAllMeshes and then put the viewport back into a shaded mode?
Are the units in the two documents the same? Can you post the 3dm file?

Hello - can you please run EvaluatePt and snap a point or two on the ugly geometry? What are the point coordinates reported at the command line?


I’m wondering if the units were different from one file to the other and that there was an automatic scaling on the paste to the new file and it’s now maybe “far from the origin”… Also I seem to see mesh wires in the second image, but the first does not seem to be mesh objects…?

Thanks for your help!
Seems like “ClearAllMeshes” solved the problem.
After running the “ClearAllMeshes” command the issue was semi solved, meaning a part of the geometry was still ugly (see image below) but after exporting and reimporting the geometry the issue was fixed complety.

This is the file comparing the two geometries. geometryissue.3dm (7.2 MB)
Snaping points to the geometry was never really an issue, as the wireframe was correct even in shaded mode (see image below)
The filie units were in both cases Meters, so that should not be the issue. A thing I should mention is probably that the Geometry was created in proximity to 0,0,0 in the original file and pasted on georeferenced coordinates.

Best Regards!

Hi Leopold - thanks for that. Could you explain the exact workflow here? You have the original file open in one session, select objects, … ?

Hi wim,
yes exactly i had both the original and the destination file open. The Workflow was the following:
Original File - Select Objects >> Ctrl+C
Destination File - Ctrl+V >> move Objects with the Gumball to the target destination.

Thanks again, Leopold.
It looks like there are 2 issues here.

One is the general case where display meshes are not automatically updated when an object is moved to a far off location. The other is that extrusion objects are not rebuilding display meshes correctly after a forced clearing of those meshes.

I’ve filed these as RH-54464 and RH-54463.