VisualARQ Elements Automatically Exploded

unhandled

#1

Hello - Has anyone encountered an issue where you have a huge model and at some point all the elements explode and the VisualArq floor levels disappear as if the file was converted to a non-VisualArq project? This is scary because I lost some hours of work and am reluctant to redraw the elements if this happens. Is there something I should watch out for that might trigger this? I’m using VisualArq 1.9.7 thanks!
Don


#2

Hi Donald, this problem might have happened if Rhino crashed for some reason. Was that your case? When Rhino crashes it saves a RhinoCrashDump.3dm file where the VisualARQ objects have turned into block instances and there’s no way to recover their parametric properties in this file. Do you remember what command or operation were you doing when Rhino crashed?
Check out your Autosave folder (you see where it’s located from the Rhino Options dialog > Files) just in case you have a copy of your model before it crashed.
Any clue that help us to figure out why Rhino crashed would be a big help to prevent situations like this happening again.


#3

Donald, I’ve had this issue as well. It is scary. It breaks down and just describes the thing as a Tibidabo object.

Best I can tell, it happens when I have had two copies of rhino running at the same time. The VA license may not be set up to do this and it drops the plugin from the one of the models. I’ve also experimented with using the geometry model as a block which is inserted in a “sheet” file for cutting plans and sections. This works ok the first time its set up. However when I change the model and update the block in the sheet file it drops the association and makes it tibidabo again. I’ve tried this in VA1.9 and have yet to try it in VA2.0. I know there is more functionality with blocks across files so hopefully this issue has been resolved.


(Enric Marquès) #4

Hi @arcus,

The VisualARQ license allows to run as many instances of Rhino as you want, so this is not the problem.

This problem seems very serious. There are some situations when VisualARQ objects are identified as “Tibidabo Custom Objects” that I know, and all of them are not normal:

  1. Tibidabo (a core VisualARQ plugin) is loaded but VisualARQ don’t. For example. load-protecting VisualARQ plug-in bug not Tibidabo.
  2. Trying to open a VisualARQ file saved with a newest version. For example, VisualARQ 1.8 cannot open files from VisualARQ 1.9 or 2.0.
  3. Corrupted file.

I’ve tried to reproduce your problem opening several instances of Rhino, and they all work fine. Do you know the exacts steps to reproduce it? Are you using one of the files inserted as a linked block in another file?

In VisualARQ 2.0 we’ve added support for external references, so updating a linked block should work without issues. If you have a commercial license of VisualARQ 1.9, you can download and test VisualARQ 2.0 Beta.

Enric


#5

@enric thanks for the response. I’ve encountered the issue twice now. Once on a file that was around 130mb with all model geometry and drawings in one file. I spoke to Fransesc about it and thinks it was, as you described, the plugin not loading. I archive regularly so had to dig up an older backup which has not be corrupted. Apparently once the objects become tibidabo there is no fixing it.

The other time I’ve encountered it was when using VA1.9 and referencing geometry as a block from file A into file B before cutting plans in file B. When I changed geometry in file A and updated the block it dropped the VA elements into tibidabo.

Again that was done in VA1.9. I’m excited to try out the referencing aspects of VA2.0 but am hesitant to upgrade until I either finish the job I’m currently working on or VA2.0 is out of beta.


#6

Just experienced the tibidabo issue again. I opened a file made in 1.9.7 into the newly installed 1.9.8 update. Apparently the new update didn’t recognize the old geometry and it dropped the entire thing to tibidabo. I noticed it immediately and did not save over the file.

I understand there is no going back on a newer file, but is there any kind of proper upgrade process when opening an old file in a newer version?


(Enric Marquès) #7

Hi @arcus,

We’ve detected that sometimes the update installer fails without showing any error, and the VisualARQ.rhp file is deleted. When this happens, there is no VisualARQ plugin, so all VisualARQ geometry is handled by Tibidabo. Can you check in the Rhino Options Plug-In Manager if VisualARQ is listed? Running the installer again and selecting the Repair option should fix the problem.

Files saved when VisualARQ plugin is missing should be working normally after VisualARQ is available again. If that’s not true, please, let me know and send me one of those files.

There is no special upgrade process. We still have to discover when and why the update fails. Do you have VisualARQ 2 RC installed?

Thanks,

Enric


#8

I do not have VA 2 RC installed.

After a bit of narrowing it down I figured out what’s causing the issue but am not sure why.

In the file showing tibidabo objects I pulled up the block manager, found a linked pdf (in this case it was the project survey sheet) and deleted the pdf. Then I did a ‘save as’ new file and closed the current. I opened the new file and when it asked if I should update the missing block I said no. All VA objects where restored. I’ve tried a number of different methods around this and it seems somehow related to the linked pdf in the block manager.

I’ll PM you the file so you can play with it.


(Enric Marquès) #9

Hi @arcus,

I’ve been trying to reproduce your problem using the file you sent, but I cannot reproduce it.

Let’s do some checks:

  • Are you using Rhinoceros 5.0 SR14? It is the 64-edition?
  • Do you have any other third-party plug-in installed? Could you disable it during the test?
  • Can you make sure both “Tibidabo” and “VisualARQ” plug-ins are enabled in the plug-in manager?

Here is an screenshot of the plug-ins that does not ship with Rhino in my case:

These are the steps I’m following:

  • Open a new instance of Rhino 5.
  • Run the command File > Open and choose the file you sent.
  • When asked to find for missing linked files, I click “No to all” button.
  • The file is opened, and all VisualARQ objects are there, no Tibidabo Custom Objects.

Thanks,

Enric


#10

Are you using Rhinoceros 5.0 SR14? It is the 64-edition?
-Yes.

Do you have any other third-party plug-in installed? Could you disable it during the test?
-I was running grasshopper, octane render, and rhino-to-unity, all of which have been disabled for the test. I then restarted rhino and reopened the same file and continued to get the tibidabo object.

Can you make sure both “Tibidabo” and “VisualARQ” plug-ins are enabled in the plug-in manager?
-Confirmed they are enabled.

I can still get the error on my end. However it is solved by removing the linked pdf.


(Enric Marquès) #11

Hi @arcus,

I’ve been able to reproduce the bug, and I think I’ve fixed it, but I’ll need more time to test it, because the fix modify some core functions and I don’t want to break anything else. I’ll try to include this fix in VisualARQ 1.9.9 and VisualARQ 2 RC3.

Thanks,

Enric