VisualARQ 2 - Version 2.1 released


VisualARQ 2.1 is now available for download.

This release includes a really big change: support for Rhino 6. Please, take into account that although this version has been tested internally, there could be still some issues, specially when running on Rhino 6. Report any problem or suggestion here or send us an email to

Here is the list of changes:

New features:

  • Support on Rhino 6
  • Help available in Japanese.
  • The Import button to select blocks for the Furniture and Element object styles accept now any file format supported by Rhino.
  • New vaFlip command to reverse the direction of walls, curtain walls, doors and windows.
  • Grasshopper Components
    • Added “IFC Type” and “IFC Tag” to assign ifc properties to geometry from Grasshopper.
    • Added “New Parameter”
    • Added “Get object Properties”
  • Curtain walls are detected as spatial elements when inserting spaces.


  • Czech strings and UI have been temporarily removed.
  • Space label control point is placed in the center of the label.
  • Grasshopper Components:
    • The “Hatch Create” and the “Text Create” Grasshopper components have changed.
    • Added “Height” input to the Space Options component.
    • “Shape curve” input names have been changed by “Path curve”
  • VisualARQ licenses licenses needs to be validated when added in a Zoo Server.

Fixed bugs:

  • A specific hatch pattern was not shown properly in sections.
  • Shed roofs were changing the slope when they were moved vertically.
  • Roof with an object subtracted didn’t show the control points of that object.
  • Moving control points of hip roofs was causing errors in some cases.
  • Adding a boundary to a roof was not working in some cases.
  • Scale factor for Furniture and Element objects was shown in distances.
  • Control points on Hip roofs didn’t work properly.
  • A second slab was being created after creating a slab from a curve.
  • Fixed a bug when importing a window style created from a Grasshopper definition.
  • Grasshopper Components:
    • Some error messages were reporting missing components when opening a VisualARQ document.
    • Some Object Create components were shown red incorrectly when some information was missing.
    • Wrong computation of a wall area.
    • Error when creating a spiral stair from Grasshopper.
    • Error when generating a slab from a Rectangle component.
    • Fixed a bug that was making columns be baked in a wrong position.
    • Set Property component was not working with certain texts.
  • IFC
    • Columns from IFC files generated in Tekla were not imported with the right size.
    • Fixed a crash when opening an IFC file.
  • Hidden Vector Output:
    • Fixed a bug when printing walls.
    • Section Hatch color was not printed correctly.
    • Fixed a bug when printing the section hatch of solids with holes.
  • Fixed a bug related to the the alignment of the cell component of curtain walls.
  • Some curtain wall muntis dissappeared when inserting doors.
  • Fixed a bug when using a curtain wall as infill of another curtain wall.
  • Fixed a bug when mirroring a wall.
  • A surface could not be selected to list it in a table.
  • Plan reference views of other levels were hidden by solids of the current level.

Known bugs and limitations:

  • Expressions in Grasshopper Params are ignored when displaying the value on VisualARQ properties panel.
  • Rhino 6:
    • Network license mode is not working. VisualARQ will report “Error 312”.
    • When loading VisualARQ, Grasshopper may report a big list of errors. In this case, all VisualARQ styles defined by a Grasshopper definition will not work.




You are right wit RH 5 version - I must update to say if it works and I didn’t

I’m sending you the file on e-mail.

Is the installer for Rhino 6 only? If so, is there a Rhino 5 version of VA 2.1, too?
Thanks a lot!

Hi Eugen,

VisualARQ 2.1 is available for both Rhino 5 and Rhino 6.

You can download the latest update from:



Got it, Enric, thanks!
I overlooked that the email contains links to all verisons… =}

I keep getting the error 312, am not sure what to do.

@ramyawild this worked for me

Hi @ramyawild,

Please, try to follow the steps that @aitorleceta mentioned. If the bug persists, let me know and we’ll try to find what’s going on.

Thanks @aitorleceta!


Hi VisualARQ team, just wanted to let you know that the download speed from your website is really slow - it’s been about 1 hour and I’m at 60% downloaded of the 90mb trial version. Makes it really hard to try your software!

PS - I’m in Australia but that shouldn’t cause an issue - I have 130/120 Mb/s here …

1 Like

Hi @camnewnham,

Our installers are hosted on Amazon S3 Europe. Here in Barcelona the download speed seems fine (10+ MB/sec), so maybe it was a temporary problem on Amazon Services, in your ISP, or in the connection between Europe and Australia.

Have you managed to download the installer? I can upload it to a different server if you still need it.



@enric I also experienced the same very slow speeds in China (last week) on a prior attempt where I ran out of time.

I managed to get it eventually - just wanted to let you know in case you want to look into it.

For comparative purposes, a speed test of my location to AWS S3 EU Central 1 - I get 2.5-3 Mb/s (

Downloading VisualARQ I get 100kb/s for ~1s, after which it drops to under 20kb/s (and just spikes around a bit in general)


EDIT: In fact it stalls altogether… My connection here is through a university and very stable.


Can you please test your speed against the Amazon S3 west european datacenters:



Take into account that these values are Megabits per second. So if you have a 120Mb/s and you’re getting 2.5Mb/s, your download speed from Amazon S3 Europe is not as good as it should be. In the last test I get a solid 250Mb/s, but I’m closer to the servers.

I don’t know if there is nothing I can do, as Amazon S3 services seems to work fine.