Visual Studio and Rhino 7 Mac

Just installed Rhino 7 and can’t get Visual Studio 2019 to run it for love or money.

Looked everywhere and found nothing. I didn’t thing it would be that hard.

Perhaps it isn’t :frowning:

All I want to do is debug my C# Grasshopper components and have Visual Studio run Rhino 7 and not my de-licensed version of Rhino 6.

Thanks in advance for your help.

John O’Keefe

Problem solved!

It turned out it was an easy solution once you’ve found the right button(s) to push. This of course, depends on whether you’re on Windows or Mac and which version of Visual Studio you’re using.

To be clear, the solution I’m going to describe is for a Rhino 7.3.21039.11202, 2021-02-08, using Visual Studio 2019 Version 8.8.10 (build 2). I’m creating a Grasshopper components in C#.

You have to change the Project Options. You can find it in the Solutions sidebar (mine is on the left) on the SECOND line from the top that has your project name. (Please see the attached image.) I don’t know what that’s formally called but the line above it, which looks exactly the same, and has no label that I can find to differentiate from its “identical” partner, has an (ever so slightly) different menu when you right click on it (Poor software ergonomics IMHO.) At the bottom of both right clicked pop-up menus, you will find something called Options. If you started out on the SECOND line from the top, then click on Options you will get the screen you’re looking for. Under Build you will find your very own Holy Grail, the settings for Rhino! You can’t find this anywhere else. And believe me, I tried. Click on the Rhino settings at the bottom and you will see a drop down tab for Launcher. Open this and select “Custom”. This will then give you a chance to fill in a box. There’s no file search associated with this, you have to type things in. (Did I mention poor interface ergonomics?!) For my machine (Mac OS Big Sur 11.2.1) and I’m sure many others, the text you need to enter is “/Applications/Rhino”.

There, you have it. Your de-bugger – or at least my debugger – will now start with Rhino 7.

I hope this helps anyone who might be running into similar problems.

John O’Keefe

VS and Rhino 7 Mac