Visual C++ creating first plugin error

Hello,

I followed the tutorial creating first plugin in C++
http://developer.rhino3d.com/guides/cpp/your_first_plugin_windows/#adding-a-command

and when I build and install the plugin called Test in Rhino, it does nothing

Could anyone suggest why it does not work. I was expecting to see
“The Test command is under construction” message

Thank you.

Best regards,
Sunayana

The first time you need to register the plugin with rhino. Find the .rhp file that was compiled and drag it onto the rhino program window. Then rhino knows where to find your plugin, and you should be able to run you test command. If you close rhino normally, the locating of the plugin is saved in the Windows registry, and rhino will find your plugin automatically the next time.

Hello Menno,

Thanks for your reply. I did register the plugin with rhino by doing what you suggest, but before I was going through
Tools > Options > Plug-ins
and then installing the plugins. In fact in
Help > Plug-ins > Test
does appear but I get the same error message as before:

Rhino debugging error dialogs enabled. Use the “TestErrorCheck” command to adjust settings.

I do not really understand why this is happening. Any help would be much appreciated.

Thank you
Best regards,
Sunayana

Ah, ok. What you see is not related to your plugin, it’s just messages. You need to run the command by typing its name in the command line.

Thank you Menno, that helped and it works now.

Best regards,
Sunayana

Sir, I face the same problem my Test did not apear on the Rhino tool option and i could not install it.

Hi @GHumera,

We will need more information to be of any help.

  • What version of Rhino are you using?
  • What version of Visual Studio to you have?
  • What error message are you getting?
  • Any other details?

Thanks,

– Dale