VirtualFrameBuffer Zooming to topleft corner not the cursor position

VirtualFrameBuffer Zoom always to topleft corner and not the cursor position in Rhino 6,7 and 8 also in SR 7.
I would suggest to add a “ZoomToFit the VFB-size”, a “ZoomToCursor” and a “Preserve the position and scaling of VFB” option to Rhino 8 and backport to 7.