Viewports not refreshing


(Wim Dekeyser) #1

Running January 10th WIP (1).

Often (2) when in a multi-viewport environment (either standard 4 views or with a floating viewport on a second screen), only the active viewport will react to changes in the zoom level or selection status of objects. In the screenshot below, I launched Rhino, pasted a curve object from RH5 with the RIGHT viewport active and then called ZEA (zoom extends all). I then clicked in the TOP viewport, thus unselecting the curve. As you can see, only the RIGHT and TOP viewports are zoomed in on the curve and only the TOP viewport shows the curve as unselected.

(1) - But this has been going on over a longer timespan and also happens on RH5.
(2) - I haven’t found a fool-proof way to consistently reproduce the issue. It might be fine for a few hours one day and then happen all the time the rest of the day. Other times, like today, it starts right away, …

It’s totally unrelated to any geometry but here’s the system information (but note that it also happens on another laptop with different GPU and driver)

Rhino 6 SR0 2017-1-10 (Public Build, 6.0.17010.13211, Git hash:master @ ae05d8255435c4cb4dce04e9d8b1de99bc72f74f)

Windows 7 SP1 (Physical RAM: 31Gb)

Quadro K3100M/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 368.39)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: None
Anisotropic Filtering Mode: None

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 6-2-2016
Driver Version: 10.18.13.6839
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit” n/a
C:\Users\dekeysw\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\Iris.WIP.rhp “Iris” n/a
C:\Program Files\Rhino WIP\Plug-ins\IdleProcessor.rhp “IdleProcessor” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Rhino Render” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI” n/a
C:\Program Files\Rhino WIP\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” n/a
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” n/a
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement” n/a


(Pascal Golay) #2

Hi Wim - do the other views update if you pan a little or something to force a redraw?

-Pascal


(Wim Dekeyser) #3

Hi Pascal, yes, each individual viewport will update when panned.


(Steve Baer) #4

Is this still happening in the latest WIP?


(Wim Dekeyser) #5

Hi Steve,
I haven’t seen this happen in the current WIP yet, no.
I’ll keep an eye on it.
Thanks!