Viewports doesn't response, just in "Safe Mode"

I’m having a problem with Rhino 7, the same goes for Rhino 6. The problem is that all the four viewports don’t seem to refresh or actualize until I click on the upper left corner of any of the viewports, the one with used to select the view (“top”, “perspective”, etc). The program seems to run fine in “Safe Mode”. I can update a picture of an of the things on the list “Things that I have tried” if it is needed.

Things that I’ve tried:

  • Set “High Performance” in every single way that I found (Nvidia Control Panel, Rhino inside configurations, on “Graphics performance preference” )
  • Download and do a “Clean installation” of the latest driver version of my graphic card
  • Try another version of the Rhinoceros
  • Reinstall the program
  • Deactivate the plug-in “RhinoCycles”
  • Deactivate “GPU Tessellation”

Rhino System Information:
Rhino 7 SR1 2020-12-8 (Rhino 7, 7.1.20343.09491, Git hash:master @ 350b20978b4fcd75493212fbd3c4248983612f86)
License type: Evaluation, build 2020-12-08
License details: Stand-Alone
Expires on: 2021-04-02

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel® HD Graphics 630 (Intel) Memory: 1GB, Driver date: 6-2-2017 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce GTX 1050 Ti (NVidia) Memory: 4GB, Driver date: 12-11-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 460.89
> Integrated acclerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: None
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-11-2020
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

My setup:

  • Processor: Intel® Core™ i7-7700HQ CPU @ 2.80GHz 2.80 GHz
  • RAM: 16,0 GB
  • OS: Windows 10 Home
  • System architecture: 64 bits
  • Dedicated graphics card: NVIDIA GeForce GTX 1050 Ti (version:
  • Integrated grapichs card: Intel® HD Graphics 630 (version:

Topics that are similar to my problem:

A picture of the program when it opens:

Obs: English isn’t my born league, so maybe I’ll write something wrong :confused: sorry for that

I found out that my Intel graphic cards drive was out of date, if you use an Acer computer you have to install the latest version manually. Hope it helps someone :slight_smile:

Yup. Old Intel driver.
This is a very common problem with these Hybrid laptops.

Here’s a link to keep handy:

1 Like

Does this apply to the integrated intel gpu’s on the workstation cpu’s like i7 10700k etc too?

1 Like

What I recommend from now on is to open the details of your graphics card by yourself, see the date/version of It and them you go to the respective company site and view the date/version of the latest driver. If your is out of date download the latest driver as .zip, extract in a folder in someplace at your computer and then put the computer to update with drivers that are already on the computer, select the folder you have extracted the latest driver and it’s done.

Hope it was useful :slight_smile:

Hope it got understandable.

No. I have a Dell tower. Both of my monitors are plugged into the Quadro directly. Nothing is plugged into the Intel port on the back of the case. I’ve even disabled the Intel GPU in Windows Device Manager. It runs beautifully.

1 Like

Thanks, good to know.
I have never had issues with hybrid laptops my self, but some customers have. For those I recommended making rhino profiles in the drivers and that always worked.

Do you recommend doing that, or was it just a safety pro caution?

I don’t think it mattered much other than I don’t need to think about driver updates for it.

I think the V6.32 and V7 installers create those Rhino “high performance” profiles now, but they don’t always work depending on the GPU, current drivers and state of Windows OpenGL.

I guess the “take away” here is laptops with Hybrid graphics always need to be configured correctly for Rhino.
The user always has to manage it.

Kyle’s post has been very helpful in that regard:

No it’s specifically for laptops.

The hybrid issue is specific to laptops as the goal with the hybrid system is to preserve the battery , as such the machine tries to send all the work it can to the intel because it uses a lot less power which extends battery life.

Towers never run on batteries so they don’t have this issue,

Ok, so a workstation with an intel chip with an integrated gpu (say the 10700k) will automatically ignore the intel part once a dedicated graphicscard is detected?


can’t deal in absolutes as the second I do, someone will show me some weird set up that proves me wrong… but yes that “should” be the way it works.

1 Like