Viewport transparency slowdown - bug


#1

I have locked objects set to transparent - even 2-3 objects behind each other slow the viewport to a crawl once they take up enough viewport space

On rhino for mac the framerate feels <10fps once i move close in on a few transparent objects, while Parallels with windows 10 on the mac (virtual machine!) can handle the same scene without a problem.

on mac the slowdown is directly related to the number of objects drawn on top of each other, while on parallels it does not seem to matter that much how many objects are drawn.

Unfortunately i can’t give a better description, but i bet there is something wrong in the display code related to transparencies…

non-retina, nvidia gt 755m, el capitan

edit:
if i switch the lighting method to ‘no lighting’ the slowdown is gone.
‘use advanced gpu lighting’ has no effect

edit2:
cull backfaces did the trick
still this looks like a bug? on windows i can have ‘use front settings’ without any problems


#2

sorry to bump this…
observed the same problem on a different machine. it is very fillrate dependent - on smaller screens it is not that bad, but still noticeable

can anyone confirm this?


(Dan Belcher) #3

I’m not able to reproduce this on my end with just guess-work. Can you please share a file where you are seeing this?

Can you please provide some additional information? Please navigate to Rhinoceros > About Rhinoceros > More info… > Copy to clipboard and paste the content back into a reply here.