Viewport Render Shadow Quality

I did try that over here and the effect was barely noticeable.

In order to make sure Rhino actually renders according to the Scaling set in the Display options you need to log out from Windows and then log back in. You also need to make sure the monitor with higher than 100% scaling is the primary monitor before logging out and back in.

Start Rhino and open a non-trivial model in Arctic mode. Now do TestToggleSkylightDowngrade. See any difference?

Here are two screen shots of before and after on my computer:

Before (low res skylight shadow):
HighDpiSSAO

After (native res skylight shadow):
HighDpiSSAO-ToggleOff

Can you send me the model (if it is non propriatary) ?
We will then compare apples to apples (or ship to ship ;)) so to speak.

It can be found here: https://free3d.com/3d-model/heavy-cruiser-suzuya-43441.html

Indeed, @DavidEranen this appears to be a result of the downgrade…
If this affect all users on a laptop then it seems to me it needs to be pretty obvious to them what to do when they see this issue.

Hi David - so it looks like the Skylight shadow quality is now hooked up to the main display mode shadows memory size / quality slider?

Are they really connected ‘behind the scenes’ or this is just so there is no new UI introduced?
There are some scenarios when one may want sharper/better quality cast shadows but just fast AO… so I thought the idea was to have a separate slider for Skylight quality.

Also, now the Skylight quality actually affects its darkness/density, so the high quality shade becomes very dark. That is another big wish to be able to control the intensity/radius of the Skylight.
The only way I can try to do it now is by changing the Environment intensity but it has other undesired effects like overburning material colors etc. (in Rendered mode any any non-artctic mode that uses Skylight…)

Having more control over this effect to make it work per-model would be great to have. Now many models over here turn too dark with Skylight and I know that is an arbitrary preset now that will work for some people and for some will not. That’s why I propose you guys considering letting us control that individually.

thanks-

–jarek

Jarek

There’s no technical connection. But the slider is basically “shadow quality”, so it should also improve the quality of the skylight shadows. We’re not going to add separate sliders if we can possibly help it. The idea is to make everything as good and intuitive as possible out of the box.

I’m not seeing things become darker - I mean, a tiny bit as areas that should have been shadowed get filled in by the better sampling, but not much.

Show us what you’re getting. If need be, we will tweak the setting.

  • Andy

It is a good idea to have a nice ‘default’ look. I am afraid also a ‘mission impossible’, unless you assume we all just work on shiny bolts in studio setting. For product, jewelry, architecture, marine, urban and many other fields, the ‘looking good’ criteria are very different. Rhino is lucky and unlucky enough to be used in all of these fields and even with best intentions you cannot possibly predict all of the scenarios. That’s why it is so important to keep things flexible and customizable. Hide it in “advanced” pulldown if the worry is too many settings for newcomers. But there is plenty of advanced users here that need more customization.

I will work on preparing samples and a longer write-up on this.

That’s the problem. What you have works OK on many models. But on many it doesn’t - so - you tweak it to work with one, the other will stop looking good. OK, I know, samples!

The bottom line with this and many other of the Display UI Customization wishes is I am trying to argue with the notion that you would be able to make it work one-for-all.

–jarek

2 Likes

Agreed - and more advanced tools are coming, but for now what we want to ensure is that a novice shouldn’t press the render button, switch to rendered, or switch to raytraced and it looks like crap.

And send samples of what you’re seeing. I literally can’t do anything until I see what you’re talking about.

Great goal!

Wondered about that too, though laudable goal nonetheless. I’m afraid one is going to need to get one’s hands dirty, at times. Par-for-the-course, however.

Back the OP and shadows, specifically Arctic shadows: Arctic is a great addition, particularly for quick form study without any effort, etc. However, I get undesirable results (disruptive large shadows) when the model consists of tubular elements perpendicular to the ground plane. Can anything be done?

Less disruptive when there is significantly more ‘mass’ casting to the ground

Non disruptive result in Raytraced.

Either way, Arctic is a welcome option. Thank you!

Are you certain of this supposition going forward? I’m not. I could be wrong…

Well, if you compare a 15" HD or 4K tablet screen with a 28" or 32" desktop monitor, the 15" will certainly have more dots per inch.

The shadow algorithm doesn’t know what’s behind the legs of the chair, so it assumes the cylinders actually extend backwards and therefore you see a lot of shadows there. This is a trade-off between speed and realism that is often done in real-time graphics.

I would recommend using Raytraced for the final render, especially when you have cylinders like in your model.

Regarding the high-dpi question, I am not certain but I’d say it’s a good guess.

What I find strange/confusing about Shadows, Skyline and Artic mode is the following.



I see two problems:

  1. The ground shadows in the first example are out of control. Too much. Waaaaay too much. It looks like the product is sitting on a white background that has a spray painted black area right where the product sits.

Here’s an example of what the ground shadow should be:

  1. When shadows are off (my third posted image), Artic should still look like Artic, like this:

I faked it using this:

Your Arctic mode is not set to defaults.

Arctic would never be used for final renders as a SOP, FWIW, but thanks for the clue.

Got it - was not sure if it was the algorithm that is not so bright at the task at hand, or just me that is a tad dim…:wink:

HI Andy,

I reset to defaults. The intense ground shadow is now fixed, that’s great!

…but turning shadows off still creates an undesirable result:

It looks like the display is turning off the per-pixel pipeline. @DavidEranen- could you take a look at this?

Yep I’ll look at it now.

This is fixed. Will show up in the next WIP.

1 Like

RH-43016 is fixed in the latest BETA