Viewport Properties not Working in Latest WIP


#1

Just tried accessing Viewport Properties – doesn’t seem to be working in latest WIP.

Shut down and restarted Rhino WIP, same result.

jvm


(Brian James) #2

I’m not seeing that here in the latest build of the day and also didn’t run into it with this weeks WIP. I checked accessing the viewport properties in the Properties panel with nothing selected and also by running the ViewportProperties command to open the Properties panel.

What’s your workflow for comparison?


#3

Hi Brian.

I’m on an Asus laptop running Windows 10. Didn’t have the issue with the
previous build.

Tried the drop down menu and command line ViewportProperties – nothing.
Restarted laptop as well, no change.

FWW, here’s system info:

Rhino 6 SR0 2017-4-4 (Rhino WIP, 6.0.17094.9041, Git hash:master @
e64a2190d3ce5b485c1c8163d9471550ab7324a6)
Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
GeForce GTX 670M/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 376.09)
OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: None
Anisotropic Filtering Mode: None

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 11-24-2016
Driver Version: 21.21.13.7609
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 3 GB
C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Rhino Render” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” n/a
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit
UI” n/a
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp “Snapshots” n/a
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” n/a
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” n/a
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp "3Dconnexion 3D Mouse"
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement” n/a


(Brian James) #4

If I understand correctly, you aren’t seeing the Properties panel show in the UI at all after running the ViewportProperties command or selecting Object Properties from the Panels drop down menu. Is that correct?

If so, can you run ToolbarReset and let me know if the issue persists? I haven’t heard this from other users since Tuesday and your system specs seem fine to me. I’m wondering if there was a crash that messed with the UI preferences.


#5

Hi Brian. I used the ToolbarReset, still doesn’t work. That’s correct, the command ViewportProperties is there, but when I access the command either through viewport or by way of command line, nothing happens.

I can download latest build and install. If it’s still happening, will let you know.

Best,

Jim


(Dale Fugier) #6

The ViewportProperties command simply displays the Viewport page in in the ObjectProperties panel. It doesn’t bring up a separate, modal dialog…


#7

Thanks Dale, completely missed that when I jumped to the WIP, so used to the modal.

Best,

Jim