Viewport printing issues


#1

I have been experimenting with printing viewport content, this is a screenshot of the viewport:
Rhinotest.pdf (137.2 KB)

And the result as a pdf “print” (lower-left button in the printing window):

Rhinoprinttest.pdf (840.6 KB)

I noticed two things: first, the viewport content has been extended to match the paper size. Is this intended behavior? I would prefer wysiwyg, or at least that possibility.
Second, I have set my viewport to have black single color surface edges, which I find best for instructional type pictures, but the print shows a lighter shade of the surface color. Is there a setting I have missed?

Max.


Strange results for raster-printing Layout
#2

Does ‘View capture to file’ work on the Mac?

Try typing that and see if it works, sorry I don’t have access to a Mac to check it.

Cheers

Andy


#3

It works with limitations, see my post in this thread: View Capture to File, New Dialog Box?. What is the connection?

Max.


#4

Sorry dude, when I was using the Mac Beta version the printing options were always WIP and I haven’t used it it a couple of months so I don’t know where they’re at with the progress.

Well, capturing the view is second best I guess, when it works

Hope you get it sorted.


(Dan Belcher) #5

Hi Max-

Sorry for the slow uptake on this.

I noticed two things: first, the viewport content has been extended to match the paper size. Is this intended behavior? I would prefer wysiwyg, or at least that possibility.

Have you tried the new Window > Set feature in the Output and Scaling section of the Print window?

…or am I completely missing the point? I find I’m able to get exactly the area I want in my print using this method, rather than messing around with viewports.

Second, I have set my viewport to have black single color surface edges, which I find best for instructional type pictures, but the print shows a lighter shade of the surface color. Is there a setting I have missed?

Hrmmmm. I think may be a bug. We have a number of similar issues on our list that relate to edges, curves, and hatches not printing correctly. I’m logging this one in MR-1557. Update: actually, reading this again, I’m not so sure I can replicate this. Can you send along a screenshot of the viewport whose surfaces are darker than the printed pdf posted above?


#6

Hi Dan,

Not to worry, I am not in a hurry and I am appreciating your reply. I did miss the window setting option, sorry. I will try that next, but in the meantime I have been experimenting with the View capture to file command, see my posts in the subject thread. With a bit of help from others I got that to work, so I am fine for now.
About the surface edge colors: I am not sure what you are asking. Both the screenshot (black edges) and the print (light colored edges) are in my opening post, what else should I show you?

Max.


(Dan Belcher) #7

Sorry, I got mixed up…I was only looking at your second PDF. Let me look into this more…


(Dan Belcher) #8

Do you have Print Width for these objects set to By Layer?


#9

Yes.


(Dan Belcher) #10

FYI: I haven’t forgotten about this issue (we’re a bit busy with the new OpenGL bugs in the latest WIP).


#11

It has not been resolved in 5A751 :disappointed:

Max.


#12

We are now on 5A772w, and the issue is still there. Has it ever been registered as a bug?

Max.


(Brian James) #13

Hi Max,

I’m trying to get a handle on what you’re still seeing that hasn’t been resolved but I’m totally confused! Can you break it down for me again and post any needed files to reproduce it? I’ll make sure it’s filed.

My best guess is that the open issue has something to with edge color when using ViewCaptureToFile. Is that right?


#14

Hi Brian,

No, it concerned the Print function, and more precisely the display of the polysurface edges in the Shaded view. I tried it again, and I realized it was probably my mistake all along. I should have selected the “Display color” instead of the “Print color” option. “Display color” shows the black edges that I had specified in Display modes/shaded view, “Print color” does show the edges as a lighter object print color. It all makes sense now, sorry for the confusion.

Max.