Viewport changing size - still

… and also the ability to move the horisontal borders together - and all borders together by ‘snapping’ to the middle of both the vertical and horisontal borders (as in WinRhino).
Thoughts…?

Philip

This is still happening… Can you fix it? I’d really like the borders to stay put…
@dan

Philip

Is this possible?

@dan

Philip

I believe you. However, we’ve never been able to reproduce it on our machines, so we wouldn’t know where to start a fix. That’s not for a lack of trying however. I know I’ve tried to reproduce this numerous times and failed.

As far as I can tell, this is not possible with the current state of Mac’s viewport drawing. This is the “epic” issue for tracking this sort of request: RH-54392 Rhino for Mac’s Viewport area is not customizable.

I have been fussing with this this morning and I cannot reproduce it. I know that is not much help, but …

-Pascal

it also happens on my computer, i reported it in this post

This is sad and odd. Here it seems to be happening almost every second day with different files. Oh well…

Philip

I really love the Mac version, but this is an area where WinRhino is so much better. Not your fault, obviously, but I really hope it would be possible some day in OS X also. How 'bout some sort of hack… :wink:

Philip

Philip, do you often switch between 5 and 6?

No, not anymore anyway - I don’t have V5 installed anymore :slightly_smiling_face: I do sometimes work with files that were originally made/started in V5, but that doesn’t seem to matter… I have had the same problem with an ‘original’ V6-file too.

Philip

how did you uninstall rhino 5? i may have a clue how to reproduce it, but i can do that with rhino 5 and rhino 6 involved only. i guess it has to do with some UI user file which both share.

Drag from Applications to the Trash bin no doubt.

that will leave quite a few files behind which are maybe responsible for exhibiting that issue.

Hmmm, if I remember correctly I just replaced it with V6 during the installation (of V6).

Philip

This just happened again… Rhino version 6.18.19246.01092, 2019-09-03.
I’ll send you the file.

Philip

Hi
We have tried to reproduce this in 6.18, 6.19, and the V7 WIP.
So far none of us (three so far), have been able to reproduce this.

​​​​​​​Sorry.

Very strange… :thinking: I wonder what’s wrong with my setup…
Thanks for trying, anyway :+1:

Philip

I reported this years ago, and someone (brilliantly!) found out it was because I didn’t have my sidebars (left and right) visible. My main screen is for design only, and has the four windows maximized. All other tools & Pallets are open on my secondary monitor. Once this was disclosed to McNeel, they said they COULD reproduce the problem, and said it was fixed. And it was…, mostly. Once in a while I get a slight displacement like you show in your posting (it was much worse before the fix). But 99% of the time, my windows open OK (v5). Does this jog anyone’s memory at McNeel about how you fixed it?

This just happened again after upgrading to the latest version: 6.19.19266.14182, 2019-09-23.
I haven’t had this problem for a while, but as soon as I installed the latest version it happened immediately when opening a file.

40

You already have the file - I sent it to McNeel yesterday regarding this issue.

Philip