Viewport => Capture to File Question


#1

I’m working with the Arctic viewport setting – very nice, BTW

Have been experimenting with different settings for saving screen to file.

Only file formats that seem to save work are: jpeg, png and bmp (PCX, TARGA, TIFF do not)

Have mixed results capturing files.
Can see tiling in renders, some tiles do not render. For example three of four tiles render and a fourth doesn’t. Or, all tiles render, but tile seams are apparent in the rendering.

Are these known issues?

Thanks,

jvm


(Brian James) #2

Try the command RenderArctic if you are looking for tga and tiff formats as well. This will also allow you to capture at larger than screen resolution using the Rendering panel. There is still an open issue that I believe is the same as what you’re seeing when using ViewcaptureToFile or Print at larger than screen res with OpenGL shadows enabled… https://mcneel.myjetbrains.com/youtrack/issue/RH-37143


#3

Hi Brian,

Thanks for the reply. Yes, the open issue is the same as what I’m seeing with ViewcaptureToFile – when trying to capture larger than screen res.

Okay will try RenderArctic, thanks!

Best,

jvm


(Willem Derks) #4

Hi Brian,

I was curious and tested RenderArctic.
I’m not sure it’s all that usefull to have a RenderArctic command with such different result from the Arctic displymode. This might bring about more confusion. Much like with the rendered mode verser a rendering in the past.

-Willem


#5

@BrianJ, i tested _RenderArctic too with option to render curves and isocurves the image turns full black once rendered. Can you repeat that on your end ?

@Willem, i guess it is more useful if you want to add DOF…?

c.


#6

Hi Brian…here are a couple renders of the same area with different render settings. Understand that there’s an unresolved issue with file capture from displaymode when resolution is larger than viewport. Just want to confirm what I’m seeing. These are just straight “renders”…no post settings.

A) Displaymode: Arctic – file captured from display. This is something I could work with, fast and simple – pleasing to the eye.

B) RenderArctic: File saved from RenderArtic. Had hoped to find something similar to the Arctic displaymode. Picture images don’t seem to render, much different look from the Artic displaymode. Curious if there’s a method to align settings so this output to be closer to Artic displaymode, but rendered?

C) Render: Straight Rhino render. Picture images are rendered.


(Brian James) #7

Yes, I think that’s this one… https://mcneel.myjetbrains.com/youtrack/issue/RH-37715

Yes, the shadows will be different between OpenGL and actual raytraced ones when using Rhino Render. Especially with skylight vs. SSAO shadows and when light types that can’t produce shadows in OpenGL are used. The material override is what I think is personally most useful.


(Brian James) #8

I think the main visual difference is the shadows here when comparing Arctic display mode to Rhino Render using an Arctic style material override. The way the shadows are created in each method use different technologies and I don’t think there will be a comparative setting to make Rhino Render look the exact same.

I’m thinking what is really needed then is to fix the tile artifacts from shadows when capturing a viewport to file at larger than screen resolution, do you agree?

@stevebaer @andy @DavidEranen Will be able to speak more about if this will be possible. I’ll add this conversation to the bug report too.


#9

Yes, fixing the tile artifacts from shadows when capturing a viewport to a file at larger than screen resolution would be helpful – thanks!

Best,

jvm


(Brian Gillespie) #10

RH-37143 is fixed in the latest WIP