Viewing mode display issue (final post)


#1

Hi all,
It’s been at least a couple of months I’ve noticed this problem. I reported last time but developers side seemed not seeing the same issue. Please fix this ASAP.

Demo:
http://www.screencast.com/t/XYEDyhDA

Sample file: @Helvetosaur

  • Kev

Mesh object control points / odd behaviors(Demo/file uploaded)
#2

What’s that huge sphere you see about one minute into the video? Can you post the file?

–Mitch


#3

Hi Mitch,
Yeah, that’s what I’m saying. It’s just a normal size sphere but It displays like that when I change among different viewing modes. In this case, render mode got the problem but it happened in other modes as well. It’s not about settings or micros, I realized. Sorry, I deleted the file yesterday after recording but I will update this soon

Previous demo:
http://www.screencast.com/t/saIC3t7SfL

-Kev


#4

You show the display mode settings at the end of this video. Why do you have the View Scaling set to 100? The default is 1. I’ve never changed that setting, but maybe there’s something buggy about switching between display modes with scaling. Have you tried setting all view scaling to 1, or all displaymodes back to default and see if you still have the problem?

What are your system details (are you running on a virtual machine, or anything else out of the ordinary)?


#5

It’s not the problem with scale of 1 or 100. In fact, I tried both settings but it appeared the same issue. Plus, it doesn’t make sense to users that there are settings exist and users cannot use them because they produce problems. I haven’t tried use all default settings but I think instead of avoiding problems, developers should solve the problems.
I’m running normal Windows. Thanks for the reply. :smile:

-Kev


#6

About blank


(Margaret Becker) #7

I cannot reproduce this.

First, please update to the latest service release.


Then, please tell us about your system.


(Margaret Becker) #8

It looks like something is funny here. When you set your display mode to one that has view scaling and then switch back to one that does not, the objects don’t seem to refresh their display correctly. I have recorded this as a bug.

However, view scaling is meant to be used on rare occasions when you want the view to be scaled differently in the horizontal and vertical directions, not when you want to make the whole view bigger.

http://mcneel.myjetbrains.com/youtrack/issue/RH-27533


#9

Hi Margaret,

Thanks for the reply.
I changed the scale settings because Rhino had the same issue while the scale factor was 1. I was hoping by changing scale factors, It could solve the problem. I just tested again using the default scale factors. It works this time. When the “linked view” setting is unchecked, sometimes it creates the same problem. I will record a video when the problem occurs again. (I’m sticking to scale factor 1 from now.)

System info as follows.

http://www.screencast.com/t/MsNvESVxv6to Demo

-Kev


#10

Sorry, I guess I made a mistake here.
I just tried using the latest
Version 5 SR9 64-bit
(5.9.40527.22095, 5/27/2014)

Both scale factor 1 and 100 worked. Thanks for the effort!

-Kev