Viewing an obj file with it's textures (beginner)

I’ve created and obj file with an mtl and relevant bmp files. I can open this obj file in meshlab and it loads the textures. If I load the obj file in Rhino then right click and select “rendered” - then the textures do not load. I have a colleague who does the same steps and the obj file loads as textured in his version of Rhino. Have I missed an option somewhere? We are both using Rhino 5 64 bit.

Hi Hannah,

The first thing that comes to mind is that the material setting for the object may be set to ‘layer’ in object properties. Select the model and set the material selection in the Properties panel to ‘by object’ as a test… I believe this should be the default setting though. If it is still not showing up for you after that, it could perhaps be that the Rendered mode settings have been altered on your machine. Click the edit settings button for the Rendered display mode at the bottom of the Display panel to access the full display mode settings in Options. Then restore the Rendered mode to the defaults to see if that helps. The last thought I’m having is that the ‘ignore textures’ option might be checked on the obj import settings. Please post the file or send it over to if it’s confidential and I can also take a look.

Thanks for your reply. I’ve tried the first and third suggestion and don’t believe it’s that. I’ve emailed over the file.


Hi Hannah,

Here’s a screen shot of where you can edit the full Rendered mode display settings. Click ‘Restore Defaults’ once in the Options page that pops up. I get the textures here without issue so if that doesn’t work my next guess would be that this is graphics card related. I would like to see what graphics card Rhino sees in Options>Rhino Options>View>OpenGL. If you are running Windows Rhino on a Mac through an emulator this may be the ultimate cause. If you see the GPU listed as something ‘generic’ then this is probably the case. Please let me know what you find… here or on the tech email.

Hi - This is what I have under “Options>Rhino Options>View>OpenGL”

. I’ve found the “restore defaults” (thanks for the bitmap) - it didn’t make a difference.