ViewCaptureToFile Transparency Problem

unhandled

#1

We are having some weird issue with ViewCaptureToFile and transparency in V6 (latest SR6 RC) with most of our files. Somehow some of the model edges disappear/are considered transparent.
All works fine with no transparency enabled.

Please see the screenshot and the sample model with the PNG results.
( to see the problem with PNG, open the transparent one with any app that shows transparency - otherwise the black background will make it look OK)

@Jeff - is that something you could repeat on your end with the sample file?
I think it applies mainly to some of the mesh models. But creating a sample mesh box works OK…

Sample files and resulting captures:
TestFileAndPNGResults.zip (160.6 KB)

thanks,

–jarek


(Jeff Lasor) #2

@Jarek, Can I please get your display mode(s) you’re using for this?

Thanks,
-Jeff


(Jeff Lasor) #3

Also @Jarek, you specifically called out SR6 … does that mean this used to work in SR5?

-J


#4

Hi @Jeff,

Here are 3 sample display modes. Shaded and Rendered have the issue, while the other one (BlackLines) works fine with transparency and edges. With more display modes over here, some of them work OK, some don’t. I can’t pinpoint any pattern or setting.

Sample_DisplayModes.zip (7.0 KB)

Unfortunately I cannot tell if this is a recent issue (SR6) or it has been here for a while. We are not using Rhino 6 for production and on daily basis yet - waiting for more bugs and problems to be ironed out in SRs…

Thanks for looking into it.

–jarek


#5

Hi @jeff
were you able to repeat/see the problem on your end ?


(Jeff Lasor) #6

Hi @Jarek,

Unfortunately, not yet… Using your file and your display modes, I see all the edges still…

I’ll keep trying on other systems though…if you can think of anything else that I may be missing that you have, please let me know… I do know that when I load your file, there are a ton of texture files missing…but I can’t see why that would cause any issue in non-rendered view modes… I guess something you could try is to save the file you posted here as “Save small” and “Geometry Only” … Then load that file and see if the problem still exists…if it doesn’t, then we’re on to something.

-J


#7

Hi Jeff,

I don’t think the textures missing are an issue here as it happens with many different files. If you Purge this file the missing textures are gone but the problem here persists.

In case that may help with anything, here is the SysInfo file: SysInfo.txt (2.0 KB)

I tried the SaveSmall/Geometry only but it doesn’t help.

One thing I found out though is that if I turn OFF the “Advanced GPU Lighting” and “Shadows”, the edges transparency works OK for these objects. Would that help with anything?
From what I can tell now it happens with mesh objects only, I did not see that happening on Polysurfaces/surfaces…

thanks for looking into that!