ViewCaptureToFile strange behaviour?

unhandled

#1

I’m having some strange issues with the viewcapturetofile command. It saves out either previous images or views that I don’t currently have. Sometimes it works, often it doesn’t and if it doesn’t do it once, it keeps doing it for that view. Really frustrating in the middle of my workflow.

Here’s a video that shows what I do and how it creates the wrong file. (I noticed afterwards that my music was still playing so mute that to not get distracted :wink: )


(Pascal Golay) #2

Hi Siemen - does Print (to image file) of the same view do the right thing?

-Pascal


#3

No, with print to jpeg it works well. I only tested it when it happened just now, because it doesn’t always happen.
Also I’ve never had this before or with another file and I use this command almost every week.


#4

ScreenCaptureToFile doesn’t seem to give me that issue though…


(Pascal Golay) #6

Hi Siemen - does the V6/WIP behave better, can you give that a try?

-Pascal


#8

I yesterday came across the same problem with another file and tried it with Rhino WIP and that didn’t cause the problem. I’ll keep you updated if I come across more cases like this.


(Pascal Golay) #9

Hi Siemen OK - thanks for the info - the developer did not have an idea as to what might be causing what you see in V5… I asked…

-Pascal


#10

Alright, I think I might have found something related to this.
I often use “ZS” - ZoomSelected before -Viewcapturetofile so I get a good shot from the stuff I want centered. And whenever I have the issue it always happens when I used ZS before the view capture. When I just zoom and pan to a spot, I usually don’t have this issue. Also, to solve it I now deselect everything, run ZS again and then View capture again. This has solved it so far.