ViewCaptureToFile produces blank white images

Hey, not sure if bug reporting is even useful at this stage of RH8 development - so please let me know if this is even helpful now. Here is the bug, that I encountered today:

ViewCaptureToFile

only produced a white image… this is the case in shaded as well as in rendered mode (haven’t tried all display modes to be honest)

Cheers

Hey @rudolf.neumerkel,

Can you run the SystemInfo command and post your results here?

Also, why are you using the Rhino 8 WIP? (there really isn’t anything new there yet…)

– Dale

@dale, there are two reasons:

  1. I like to be on the cutting edge of new features from time to time, as soon as they are added.
  2. I am very happy about the planned features of RH8 and want to support the development (Metal API, GH2, etc.) by just doing my daily stuff with the WIP version instead of 7 and sharing my experiences and bugs!

Btw.: the sys info:

sys_info.txt (9.4 KB)

Cheers

Thanks @rudolf.neumerkel.

Thus far, we are unable to reproduce what you are reporting. I see you have some 3rd party rendering applications that potentially can conflict.

Rhino plugins that do not ship with Rhino
  /Users/rudolfneumerkel/Library/Application Support/McNeel/Rhinoceros/MacPlugIns/Twinmotion Direct Link 2020.rhp	"Twinmotion Direct Link 2020"	1.0.6.0
  /Users/rudolfneumerkel/Library/Application Support/McNeel/Rhinoceros/MacPlugIns/bella_rhino.rhp	"Bella"	20.4.0.0
  /Users/rudolfneumerkel/Library/Application Support/McNeel/Rhinoceros/MacPlugIns/maxwell_rhino.rhp	"Maxwell for Rhino"	5.0.6.2
  /Users/rudolfneumerkel/Library/Application Support/McNeel/Rhinoceros/MacPlugIns/KeyShot9Plugin.rhp	"KeyShot9RhinoPlugin"	1.0.0.0
  /Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCodePlugin.rhp	"RhinoCodePlugin"	1.0.0.0

If you don’t mind, can you remove these and re-test?

Thanks,

– Dale

Interesting… disabled all plugins that do not ship with Rhino. Still the same behavior. For double check, here is the updated system info:

sys_info_update.txt (9.4 KB)

Hi Rudi,
I have the latest WIP build of Rhino 8 Mac
Version 8 WIP (8.0.21089.12306, 2021-03-30)
Expires May 14, 2021
I am also running Catalina macOS 10.15.7 (19H524), just for testing.

I have disabled all plugins that do not ship with Rhino under Preference → Plugins: uncheck and restart Rhino.caster and housing.3dm (4.6 MB)

And I get an image from ViewCaptureToFile one every file I try, shaded or rendered.

So try updating to the latest WIP of Rhino 8 for Mac and also try with my attached file.
Let us know if there are any difference in behavior.

Thanks for testing.
Sincerely,
Mary Ann Fugier

thanks @Mary,

I installed the RH8 version you sent. The issue seems to be resolved there - ViewCaptureToFile now successfully produces images!

Cheers

1 Like