_-ViewCaptureToFile multiple macro bugs? or changes?

Hi McNeel team,

I’m trying to bring up to date an old workflow that I haven’t used for a while (since V5 probably) and we need it again. I have some problems trying to run this:

  1. When I run this macro I get an error in Rhino not recognizing the LockAspectRatio setting:

_-ViewCaptureToFile
_Unit=pixels
_width=3840
_height=2160
_Scale=1
_trasnparentBackground=No
_LockAspectRatio=Yes
_DrawWorldAxes=No
_DrawCPlaneAxes=No
_DrawGrid=No

  1. I cannot get either my settings or my filename listened to.

If I put my file path/name first, my setting are ignored, like this:

_-ViewCaptureToFile
“F:\assets\temp_screenshots\gustavo\alpha_channels\clipboard_alpha.tif”
_Unit=pixels
_width=3800
_height=2100
_Scale=1
_trasnparentBackground=No
_DrawWorldAxes=No
_DrawCPlaneAxes=No
_DrawGrid=No
_Enter
_Enter

In this example above, I went ahead and changed my width/height from the previous 3840x2160 to 3800x2100 to see if the new viewcapture would read that, and it did not.

If I put my setting first, my settings do get respected by RHino, by filename/path destination gets ignored:

_-ViewCaptureToFile
_Unit=pixels
_width=3800
_height=2100
_Scale=1
_trasnparentBackground=No
_DrawWorldAxes=No
_DrawCPlaneAxes=No
_DrawGrid=No
“F:\assets\temp_screenshots\gustavo\alpha_channels\clipboard_alpha.tif”
_Enter
_Enter

In this case, the file got saved in the same location as the Rhino file, with this name:
ViewCapture20221223_115359_trasnparentBackground=No.png.png

So something seems seriously broken here unless I’m missing some new steps in the macro?

Thanks,

G

transparent typo?

great catch! I fixed that and it’s still tripping:

Command: _-ViewCaptureToFile
Save file name ( Unit=pixels Width=3840 Height=2160 Scale=1 LockAspectRatio=No DrawGrid=No DrawWorldAxes=No DrawCPlaneAxes=No TransparentBackground=No NumberOfPasses=500 Autoname=ViewCapture Browse ): “F:\assets\temp_screenshots\gustavo\alpha_channels\clipboard_alpha.png”
Image successfully saved as F:\assets\temp_screenshots\gustavo\alpha_channels\clipboard_alpha.png
Command: _Unit=pixels
Unknown command: _Unit=pixels

EDIT: nevermind, changing the order putting all options first and filename/path at the end, seems to be back in business now.

Thank you!

G