Viewcapturetofile in Raytraced Crashes Rhino


#1

Viewcapturetofile in Raytraced Crashes Rhino


(Nathan 'jesterKing' Letwory) #2

Works just fine here.

kuva

How do you determine it crashes Rhino? You get the crash report dialog? Or do you see the spinning wheel?

If the spinning wheel that is expected - Raytraced is doing its thing and you’ll just have to wait until render is written do disk.


#3

hi Nathan, it crashed, sent crash report


(Nathan 'jesterKing' Letwory) #4

Can you share the 3dm file that crashed for you at https://rhino3d.com/upload?to=nathan@mcneel.com ? I’ll get notified when the upload is finished.


#5

just ran it again, same result, crash, I can’t follow your link above, get a pop up window, ‘this connection is not private’ ??


#6

Try https://www.rhino3d.com/upload?to=nathan@mcneel.com


(Nathan 'jesterKing' Letwory) #7

@milezee the does not cause any crashes on my machine.

At what resolution are you trying to do the capture? What are the settings you use?


#8

Hi Nathan, tried again, same result, crash, screenshot attached of settings, also had this pop up immediately after crash (see screenshot)



(Nathan 'jesterKing' Letwory) #9

@milezee I don’t see anything out of the ordinary with your settings and resolutions. I assume you don’t have any changes to your Raytraced view mode?

@dan, do you know why @milezee sees the lldb dialog? Sounds odd a user would see that…


#10

I’ve been using snapshots of different views with different materials added if that helps narrow it down


(Nathan 'jesterKing' Letwory) #11

Does that mean that you are able to do several ViewCaptureToFiles before you hit one that crashes?


#12

no, I look at them in standard Render mode to get an idea of what they look like then was wanting to switch to Raytraced for final output :+1:


(Nathan 'jesterKing' Letwory) #13

I’ll just have to try harder to get this to crash then :slight_smile:


(Dan Belcher) #14

I’m not 100% certain about this, but I believe it is due to the confusing “two crash dialogs” problem. Apple presents a dialog and Rhino presents a dialog. If memory serves, on the Apple dialog, one of the buttons on that dialog will present something like this if it is clicked. My memory is fuzzy on this one and it is difficult to verify because I have all the tools installed (Xcode, LLVM, lldb, the whole toolchain). I might be wrong about all of this, but I suspect that is what is going on.